close

Anmelden

Neues Passwort anfordern?

Anmeldung mit OpenID

Einführung in GIMP (GNU Image Manipulation - Rechenzentrum

EinbettenHerunterladen
Einführung in GIMP
(GNU Image Manipulation Program)
G.Hessler, Rechenzentrum
Gerd Hessler
Einführung in GIMP
(GNU Image Manipulation Program)
SS 2012
Einführung in GIMP
(GNU Image Manipulation Program)
G.Hessler, Rechenzentrum
Gerd Hessler
GIMP
Programm zur Bearbeitung von Bilddateien (Bitmaps, Pixelgrafik)
Ziele:
Verbesserung der Bildqualität,
Verändern des Bildinhalts (Retusche, Filter),
Erstellen eines neuen Bildes (Komposition),
Konvertierung von Bildformaten (psd, jpg, tiff etc.).
Bitmaps:
Ein Bild (Bitmap, Pixelgrafik) besteht aus einzelnen Bildpunkten (Pixel), die in Zeilen und
Spalten organisiert sind (Bildmatrix). Die Auflösung eines Bildes ist abhängig von der Anzahl
der Pixel pro Längeneinheit. Jedes Pixel besitzt eine Farbinformation (Farbtiefe). Die
Farbtiefe wird in Bit angegeben.
Schwarz-Weiß – 2 bits
Graustufen – 8 bits (1 Byte) - 256 Graustufen
indizierte Farben 8 bits - 256 Farben (Farbtabelle)
Echtfarben oder True Color (ab 24 bits) - mehr als 16,7 Millionen Farben
Einführung in GIMP
(GNU Image Manipulation Program)
G.Hessler, Rechenzentrum
Gerd Hessler
Unterschiede zwischen Pixel- und Vektorgrafik
Im Gegensatz zur Pixelgrafik beinhaltet die Vektorgrafik keine Bildmatrix, sondern setzt
sich aus mathematisch definierten Vektorobjekten zusammen. Solche Objekte (Kurven,
Rechtecke, Texte, Bildobjekte) sind auf der Zeichenfläche durch Koordinaten- und
Winkelangaben eindeutig definiert.
1) Vektorgrafiken werden für technische Präsentationen (Poster, Plakate, technische Zeichnungen) mit übersichtlicher Struktur verwendet und mit Grafikprogrammen wie Illustrator,
CorelDraw, AutoCad sowie den freien Programmen inkscape, tgif, xfig u.a. generiert.
2) Pixelgrafiken beinhalten feinstrukturierte, hochauflösende Bildstrukturen. Die Bildpunkte
können mit Programmen wie PhotoShop, Gimp (frei), Corel Photopaint, Paint.NET (frei)
u.a bearbeitet werden.
3) Mit Vektorisierungsprogrammen können z.B. gescannte Bilddateien in Vektordateien umgewandelt werden. Der Bildinhalt muß für eine Vektorisierung geeignet sein (s.o.), da die Anzahl der Vektoren überschaubar bleiben sollte (Dateigröße !).
4) Jede Vektordatei kann in eine Bilddatei umgewandelt werden.
Einführung in GIMP
(GNU Image Manipulation Program)
G.Hessler, Rechenzentrum
Gerd Hessler
Bitmaps:
Vektorgrafik:
Bearbeitung erfolgt auf Pixelebene,
Die Bearbeitung erfolgt auf Objektebene,
Größe und Position eines Pixels kann nicht
verändert, nur der Farbwert kann modifiziert
werden,
Größe, Position und Form eines Objekts
können jederzeit verändert werden,
bei vorgegebener Auflösung verschlechtert
sich die Bildqualität bei Vergrößerung (Skalierung),
Vektorgrafiken können beliebig skaliert
werden (diagonale Linien zeigen keine
Treppeneffekte !),
Bitmapgrafiken haben einen hohen Speicherbedarf.
Vektorgrafiken haben in der Regel einen
niedrigen Speicherbedarf.
Einführung in GIMP
(GNU Image Manipulation Program)
Die GIMP - Startfenster (1)
G.Hessler, Rechenzentrum
Gerd Hessler
Folgende Fenster werden nach dem Programmstart erzeugt:
Das Gimp Andockfenster
mit Registern. Standardmäßig wird ein Fenster mit
dem Ebenen-, Kanal-, Pfadund Journal-Register bereitgestellt.
Das Gimp Hauptfenster mit
diversen Menüs. Über das
Datei-Menü wird eine Bilddatei neu erstellt, eine Datei
geöffnet oder gespeichert und
Gimp beendet.
Achtung: bei mehreren geöffneten Hauptfenstern (Bildern)
werden Einzelfenster mit
Schließen beendet. Mit Beenden schließt Gimp alle
Fenster und wird beendet.
Das Gimp Werkzeugfenster
mit der Werkzeug-Palette
und dem angedockten Werkzeugeinstellungsfenster.
Einführung in GIMP
(GNU Image Manipulation Program)
Die GIMP - Startfenster (2)
G.Hessler, Rechenzentrum
Gerd Hessler
Über das Menü Fenster kann auch ein Einzelfenster - Modus eingestellt
werden => Werkzeug-, Andock- und Hauptfenster sind miteinander verbunden.
Einführung in GIMP
(GNU Image Manipulation Program)
G.Hessler, Rechenzentrum
Gerd Hessler
Die GIMP - Startfenster (3) => Andocken optionaler Fenster
Über das Menü Fenster können unter andockbare Dialoge (Register) weitere Fenster z.B.
zur Auswahl von Pinseln, Mustern und Farbverläufen ausgewählt werden.
Mit Hilfe der Funktion 'Reiter hinzufügen' im Reiterkonfigurationsmenü oder durch
Verschieben können weitere Dialoge (Register) dem Andockfenster hinzugefügt oder über
'Reiter lösen' separiert werden.
optionales Fenster
Andockfenster
Reiterkonfiguration
Einführung in GIMP
(GNU Image Manipulation Program)
G.Hessler, Rechenzentrum
Gerd Hessler
Die GIMP - Startfenster (4) => optionale Fenster mit
Konfigurationsmenü
Im Vorder- u. Hintergrund
Farbfenster kann für
verschiedene Farbmodelle
die Vordergrund- und die
Hintergrundfarbe (VG/HG)
festgelegt werden.
Default: schwarzer Vordergrund und weißer Hintergrund.
Pinselfenster zur Auswahl
von Malpinseln. Generell
können über das Konfigurationsmenü oben rechts
weitere Einstellungen vorgenommen werden.
Im Pinselmenü steht hier ein
Pinsel-Editor (Pinsel bearbeiten) zur Verfügung.
Das Farbverlauffenster
dient zur Auswahl vorgegebener Verläufe.
Über den Konfigurationsbutton können weitere Farbverläufe editiert
werden.
Einführung in GIMP
(GNU Image Manipulation Program)
G.Hessler, Rechenzentrum
Die GIMP- Startfenster (5) => Werkzeugkasten
Gerd Hessler
Das Gimp Werkzeugfenster mit
Werkzeugkasten
Reiterkonfiguration
(Optionsmenü)
Werkzeugeinstellungenfenster
den Werkzeugen und dem Werkzeugeinstellungenfenster (Fenster-Menü => andockbare
Dialoge) zur Parametereinstellung eines ausgewählten Werkzeugs (Default: Pinsel).
Falls das Werkzeugeinstellungsfenster nicht
aktiviert (nicht am Werkzeugkasten angedockt)
ist, wird dieses durch Doppelklick auf das
jeweilige Werkzeug generiert.
Das Reiterkonfigurationsmenü mit dem untergeordneten Werkzeugmenü dient dem Speichern oder Rücksetzen von Einstellungen.
Analog hierzu existieren an der Unterseite Schalter zum Speichern von Einstellungen und zum
Rücksetzen der Werkzeuge (Default-Werte).
Schalter
Es gibt Standard- und benutzerdefinierte Voreinstellungen (via Voreinstellungsfenster).
Einführung in GIMP
(GNU Image Manipulation Program)
GIMP - Startfenster (ältere Versionen)
G.Hessler, Rechenzentrum
Gerd Hessler
Folgende Fenster werden nach dem Programmstart erzeugt:
Das Gimp Startfenster
Das Gimp Registerfenster
Aktuelle Informationen
Hinweis: Das Gimp Hauptfenster mit den Menüs ist bei
älteren Versionen erst nach Öffnen eines Bildes verfügbar!
Einführung in GIMP
(GNU Image Manipulation Program)
G.Hessler, Rechenzentrum
Gerd Hessler
Gimp Startfenster
GIMP - Hauptfenster (ältere Versionen)
GIMP Datei-Menü
Nach Öffnen einer neuen oder existierenden Datei wird das Hauptfenster geöffnet. Im Gegensatz zu den neuen Versionen werden erst
in diesem Fenster alle Menüs angezeigt.
Gimp Bildfenster
Einführung in GIMP
(GNU Image Manipulation Program)
G.Hessler, Rechenzentrum
Gerd Hessler
neue Datei öffnen
Parameter für eine neue Bilddatei:
unter Vorlagen können verschiedene StandardBildgrößen und eigene Vorlagen (s.u. Vorlagen
erstellen) ausgewählt werden,
oder unter Bildgröße kann ein Bildformat frei
gewählt werden.
wichtig: unter 'Erweiterte Einstellung' wird die
Bildauflösung (z.B. Pixel/Inch), der Farbraum
und die Hintergrundfarbe gemäß Vorgabe in der
Werkzeug-Palette eingestellt. Sollen z.B. ausgeschnittene Objekte auf einer Vorlage positioniert werden, ist ein transparenter Hintergrund
empfehlenswert. Ferner können Bildkommentare (Metadaten – s.a. Eigenschaften) eingegeben werden.
Hinweis: Grundsätzlich sollten beim Arbeiten mit GIMP die Andockfenster Journal und Ebene genutzt werden. Mit Hilfe des Journals können Bearbeitungsschritte korrigiert werden. Im
Ebenenfenster sollte stets das Originalbild dupliziert werden. Hierdurch kann u.a. das bearbeitete Bild mit dem Originalbild verglichen werden (alternativ: Duplizieren im Bild-Menü wählen).
Einführung in GIMP
(GNU Image Manipulation Program)
Hauptfenster mit geöffneter Bilddatei
G.Hessler, Rechenzentrum
Gerd Hessler
Hauptfenster mit Name. Größe, Farbmodus und Menüs zur Bildbearbeitung.
Bei älteren Versionen: das Datei-Menü bietet gegenüber dem gleichnamigen Menü
des Startfensters erweiterte Funktionen
(z.B.:Speichern).
Bild an Fenstergröße anpassen (ein/aus)
Lineal mit Hilfslinien (einstellbar im
Ansicht-Menü),
Kontext-Fenster alternativ zu den Menüs,
schnelle Maske aktivieren => Auswahl
kann durch Übermalen mit weißer/schwarzer Farbe z.B. für Feinkorrekturen erfolgen
(rot: nicht ausgewählt). Danach Maske deaktivieren => zeigt den aktuellen Auswahlbereich an,
Info-Leiste mit Maßangabe, Zoom-Stufe
und Auflistung des aktuellen Werkzeugs.
Einführung in GIMP
(GNU Image Manipulation Program)
G.Hessler, Rechenzentrum
Auswahl-Werkzeuge (1) =>
Gerd Hessler
markieren einen zu bearbeitenden Bildbereich:
Rechteck, Ellipse werden mit gedrückter Maustaste
vom Rand her aufgezogen (an Rändern bearbeitbar!).
Freihand- und Polygonwerkzeug (Maustaste gedrückt)
erzeugt eine Freihandkontur oder durch Anklicken Polygonknoten (Linienfang mittels Shift-Taste). Beenden
durch Doppelklick => Auswahl wird automatisch geschlossen (Vergl: Lasso - PhotoShop).
Zauberstab wählt einen farblich zusammenhängenden
Bereich aus. Der Auswahlbereich kann ggf. sukzessiv
über den Schwellwert (0-255 (alles auswählen))
festgelegt werden.
Wichtig: bearbeitet werden kann auf der aktiven Bildebene entweder das gesamte Bild oder ein ausgewählter
Bereich !
Strg-Taste Referenz: Auswahl-Mittelpunkt,
Shift-Taste Kreis, Quadrad
Alt-Taste verschiebt eine Auswahl
Auswahl aufheben: Menü Auswahl oder <Strg>A
Einführung in GIMP
(GNU Image Manipulation Program)
G.Hessler, Rechenzentrum
Gerd Hessler
Auswahl-Werkzeuge (2):
Farbauswahl-Werkzeug wählt gleiche oder ähnliche Farben
(nicht zusammenhängend) aus.
Umriss-Werkzeug orientiert sich an einer Bildkontur =>
1) Knotenpunkte längs einer Kontur setzen und die Auswahl
schließen (Endpunkt über Anfangspunkt).
2) Knoten können verschoben und weitere hinzugefügt
werden.
3) Die Auswahl wird durch Klick auf den Innenbereich oder
<Return> aktiviert (magnetisches Lasso – PhotoShop).
Hinweis: Zur Vermeidung von scharfen Kanten bei Montagen 'Kanten ausblenden' nutzen.
Vordergrund-Auswahl-Werkzeug:
1) Es wird zunächst ein grober Auswahlbereich (LassoFunktion) festgelegt und hierdurch eine Maske generiert.
2) Anschließend wird mit einem Pinsel (Vordergrund
markieren) der Auswahlbereich vergrößert oder über
'Hintergrund markieren' der Auswahlbereich verkleinert.
3) Die Auswahl wird über die Return-Taste aktiviert.
Einführung in GIMP
(GNU Image Manipulation Program)
G.Hessler, Rechenzentrum
Gerd Hessler
Auswahl-Werkzeuge (3):
Pfad-Werkzeug ist ein skalierbares Vektorwerkzeug, das
in eine Auswahl umgewandelt werden kann (Return oder
über die Werkzeugeinstellung 'Auswahl aus Pfad').
Modi:
Design => Pfad erstellen,
Bearbeiten => Bezier-Kurve,
Verschieben => bezieht sich auf ganzen Pfad.
Die Anzeige der Pfade erfolgt über das Pfad-Register.
Pipette-Werkzeug zur Auswahl einer Vorder- oder Hintergrundfarbe z.B zur Füllung einer Auswahl. Diese wird
angezeigt im Werkzeugfenster bzw. in der Farbpalette .
Zoom-Werkzeug vergrößert / verkleinert ein Bild (StrgTaste) mit oder ohne Fensteranpassung (s. Werkzeugeinstellung).
Meßwerkzeug liefert unterhalb des Bildfensters oder bei
aktiviertem Info-Fenster (s. Werkzeugeinstellung)
Abstand und Winkel in separatem Fenster (Strg-Taste
15° Winkel) => Ausrichten verkanteter Bilder => Drehen.
Einführung in GIMP
(GNU Image Manipulation Program)
G.Hessler, Rechenzentrum
Gerd Hessler
Transformations- und Textwerkzeuge (1):
Verschieben-Werkzeug verschiebt eine Bildebene,
eine aktive (schwebende) Auswahl oder einen Pfad.
Ebenen-Ausrichte-Werkzeug richtet Ebenen unterschiedliche Größe (z.B. Objekte mit transparentem
Hintergrund) aneinander aus oder verteilt Ebenen
(Shift-Taste) relativ zu einer anderen z.B aktiven
Ebene.
Die auszurichtende Ebene wird nach Anklicken durch
einen Auswahlrahmen markiert.
Die Ausrichtung erfolgt relativ zu einer Auswahl,
einem Bild oder der aktiven Ebene.
Zuschneide-Werkzeug schneidet einen Bildbereich
auf einer Ebene oder ebenenübergreifend aus (z.B.
verkantete Bilder zuschneiden und drehen). Das
Zuschneiden wird abgeschlossen mit der <Return>Taste. Die Ebene wird entsprechend der Auswahl
verkleinert.
Einführung in GIMP
(GNU Image Manipulation Program)
Transformations- und Textwerkzeuge (2):
G.Hessler, Rechenzentrum
Gerd Hessler
Rotations-Werkzeug dreht je nach Parametereinstellung eine Ebene,
eine Auswahl oder einen Pfad interaktiv bzw. über eine Winkelangabe,
Skalieren-Werkzeug vergrößert oder verkleinert eine Ebene, eine
Auswahl oder Pfad (konst. Seitenverhältnis => Strg-Taste),
Scher-Werkzeug schert eine Ebene eine Auswahl oder Pfad horizontal oder vertikal (Strg-Taste),
Verzerren-Werkzeug korrigiert eine Ebene,eine Auswahl oder Pfad
bei Perspektivfehlern,
Spiegeln-Werkzeug spiegelt eine Ebene, eine Auswahl oder Pfad
horizontal oder vertikal,
Käfig-Transformationswerkzeug erlaubt das Transformieren eines
zuvor markierten Bildbereichs (Polygonknoten verschieben) , Beenden erfolgt über <Ret>.
Text-Werkzeug nach dem Anklicken kann der Text direkt positioniert,
ein Text-Fenster aufgezogen oder bestehender Text editiert werden.
Es wird eine Text-Ebene eingefügt. Schriftschnitt, Farbe und Größe
werden direkt über das Werkzeugeinstellungsfenster eingestellt.
Hinweis:Zum Verschieben Cursor exakt auf Buchstaben positionieren.
Einführung in GIMP
(GNU Image Manipulation Program)
G.Hessler, Rechenzentrum
Malwerkzeuge:
Gerd Hessler
Fülleimer-Werkzeug füllt gem. Schwellwert eine
Auswahl mit Vordergrund- oder Hintergrundfarbe bzw.
einem Muster (hoher Schwellwert => vollst. Füllung).
Farbverlaufs-Werkzeug füllt eine Auswahl mit einem
Farbverlauf. Der Farbverlauf, die Deckkraft und die
Form werden über die Werkzeugeinstellungen
festgelegt.
Stift-Werkzeug (harte Kante) zeichnet bei gedrückter
Maustaste gem. Deckkraft-, Farb- und Pinselstärke der
Werkzeugeinstellung. Mittels Shift-Taste können Polygone erzeugt werden.
Pinsel-Werkzeug (weiche Kante) analog zum Stift,
=> Farbverläufe und Pinsel können über die Verlaufs- und Pinseleditoren über die entsprechenden
Werkzeugeinstellungsfenster auch individuell
gestaltet werden (Editoren => Pinsel oder Verlauf im
Andockfenster auswählen, Auswahl über Kopierschalter
duplizieren, Duplikat aktivieren und editieren (Standardpinsel- und Verläufe sind (schreibgeschützt) <=
Einführung in GIMP
(GNU Image Manipulation Program)
G.Hessler, Rechenzentrum
Gerd Hessler
Malwerkzeuge:
Radiergummi-Werkzeug löscht die übermalten Teile
der aktiven Ebene vollständig oder macht diese
transparent (Deckkraft einstellen) und zeigt die
unterliegende Ebene oder macht auf der unteren Ebene
den Bildhintergrund sichtbar.
Mit dem Unradierer kann die Transparenz wieder
entfernt werden (Unradieren aktivieren oder ALT-Taste
drücken).
Das Einstellungsfeld entspricht dem des Pinsels.
Sprühpistole-Werkzeug verteilt Pinsel-Muster (aus der
Pinsel-Palette) mit vorgegebenem Farbdruck (Stärke)
und vorgegebener Rate (Farbmenge/Zeit) auf der aktive
Ebene.
Kalligraphie-Tinte stellt einen kalligraphischen Pinsel
bereit.
Die Pinselform kann über den Schalter 'Form' der Werkzeugeinstellungen interaktiv verändert werden.
Einführung in GIMP
(GNU Image Manipulation Program)
G.Hessler, Rechenzentrum
Gerd Hessler
Kopier- und Retuschewerkzeuge:
Stempel (Klon)-Werkzeug überträgt Bildinformationen
von einer Referenzposition (Strg-Taste) auf einen anderen
Bildpunkt,
Heilen (Reparatur)-Werkzeug
- berichtigt Fehler im Bild (Kratzer),
- dient der Retusche (Falten) ggf. mit Weichzeichner und
- repariert die Kanten bei Bildkompositionen (s.a. Leinwandgröße ändern).
Die Referenz wird, wie beim Stempel, über die Strg-Taste
fixiert. Es werden im Gegensatz zum Stempel an der
Korrekturstelle Randwerte (Strukturinformationen)
eingerechnet.
Einführung in GIMP
(GNU Image Manipulation Program)
G.Hessler, Rechenzentrum
Gerd Hessler
Kopier- und Retuschewerkzeuge:
Perspektivisches Klonen-Werkzeug (Kombination von Klonen und perspektivischem Verzerren) überträgt Bildpixel gemäß einer vorgegebenen Perspektive.
Es wird zunächst ein Rahmen um den zu klonenden Bildteil gesetzt => Perspektive ändern.
Der Rahmen beschreibt die neue Perspektive der zu klonenden Auswahl (rechteckige
Rahmen keine Veränderung der Perspektive).
Nachfolgend wird eine Referenz gewählt (Strg-Taste) und der Bereich mit gedrückter Maustaste auf einen anderen Bildteil übertragen => perspektivisches Klonen.
Einführung in GIMP
(GNU Image Manipulation Program)
G.Hessler, Rechenzentrum
Gerd Hessler
Kopier- und Retuschewerkzeuge:
Weichzeichen- / Verschärfen-Werkzeug glättet
Pixelwerte über eine vorgegebene Fläche oder
verstärkt Konturen,
Wischfinger-Werkzeug 'verschmiert' Pixelwerte
(Farbinformationen) diffus oder hart je nach
vorgegebener Übertragungsrate,
Abwedel- / Nachbelichtungs-Werkzeug hellt
Bildbereich auf oder verdunkelt sie.
Hinweis: geeigneten Pinsel auswählen,
Zur Anwendung auf Auswahlbereiche stehen auch
diverse Weichzeichner- und Verbesserungsfilter
zur Verfügung (Schärfen, unscharf maskieren
Gaußscher Weichzeichner u.a.).
Empfehlung: bei den letztgenannten Retuschewerkzeugen mit duplizierten Ebenen und Transparenz arbeiten !
Einführung in GIMP
(GNU Image Manipulation Program)
G.Hessler, Rechenzentrum
Gerd Hessler
Eine aktuelle Vordergrund- / Hintergrundfarbwahl (mit Voreinstellung S/W) kann jeweils durch
direktes Klicken in verschiedenen Farbmodellen
zugewiesen werden.
Die aktuelle Pinsel-, Muster- und FarbverlaufEinstellung kann ebenfalls durch direktes
Klicken zugewiesen werden. Diese Einstellungen
sind für die Mal-Werkzeuge, das Füll-Werkzeug
sowie das Farbverlaufs-Werkzeug relevant.
=> die Anzeige in der Werkzeugpalette entfällt
standardmäßig.
Sie kann über Bearbeiten => Einstellungen =>
Werkzeugkasten optional eingeblendet werden oder wird in den jeweiligen Werkzeugeinstellung bereitgestellt.
Alle weiteren Einstellungen zum Füllen mit VGFarbe, HG-Farbe oder Muster (Füllwerkzeug,
Pinsel) sind über die Werkzeugeinstellungen
vorzunehmen.
Einführung in GIMP
(GNU Image Manipulation Program)
Die GIMP - Menüs (1)
G.Hessler, Rechenzentrum
Gerd Hessler
Datei-Menü
Das Datei-Menü umfaßt folgende Funktionen:
●
●
●
●
●
●
●
●
●
●
●
Bilddateien neu erstellen, Vorlagenformate
auswählen, Bilder von Webseite, vom Bildschirm, Scanner und Zwischenablage
(von einer Auswahl s. Bearbeiten-Menü)
erstellen
bestehende Bilder zum Editieren öffnen,
Bilddateien als neue Ebene einfügen,
Bilder über Webadressen importieren => Webseite => Grafikinfo anzeigen (über Kontextmenü),
Bilder im xcf- oder Vorlagenformat speichern,
Kopie in xcf speichern, Bild kann danach nicht
ohne Dialog geschlossen werden (für Zwischenergebnisse => Vergleiche speichern),
Bilder in Fremdformate exportieren,
Vorlagen generieren (Vorlagenformat s.o.),
Bilddateien drucken,
Bildeigenschaften (Metadaten),
Bilddatei oder Bilddateien ohne Speichern
schließen und Gimp beenden.
Einführung in GIMP
(GNU Image Manipulation Program)
Die GIMP - Menüs (2)
G.Hessler, Rechenzentrum
Gerd Hessler
Bearbeiten-Menü
Bearbeiten:
●
●
●
●
●
●
●
●
Kommando-Editoren und das Journal aktivieren (Einstellungen => Umgebung),
Verblassen modifiziert Deckkraft nach Anwendung von 'Füllen' und 'Farbverlauf',
Auswahlbereiche speichern, verschieben, einfügen (schwebend. Auswahl =>
Ebene danach zuordnen) und löschen,
In Auswahl einfügen fügt in Auswahl ein,
Einfügen als: neues Bild, Ebene, Pinsel
oder Muster aus einer Auswahl (Zwischenablage) erstellen,
Ablagen zusätzliche Speicher für Auswahlbereiche (neben Zwischenablage),
Farb- und Musterfüllung für ein Auswahl,
Generelle Einstellungen, Tastenkombinationen, Einheiten- und Erweitertungsmoduleditor.
Einführung in GIMP
(GNU Image Manipulation Program)
Die GIMP - Menüs (3)
G.Hessler, Rechenzentrum
Auswahl-Menü
Gerd Hessler
Das Menü Auswahl ermöglicht:
● das gesamte Bild oder nach Bildkriterien
(Farbe) auszuwählen bzw. einen Auswahlbereich zu invertieren,
● eine schwebende Auswahl zu generieren =>
schwebende Auswahl => nicht auf Ebene fixierte Auswahl => kann auf unterliegender
Ebene oder auf einer neu einzufügenden
Ebene verankert werden (PhotoShop: immer
neue Ebene!).
● über den Auswahleditor einen Auswahlbereich zu wandeln (in Kanal- oder Pfad),
● Ausblenden und Schärfen: bei einer Auswahl
weiche oder harte Kantenübergänge zu
erzeugen,
● Auswahlbereiche zu vergrößern oder zu
verkleinern,
● Rand, abgerundetes Rechteck, Verzerren:
die Ränder einer Auswahl zu modifizieren,
● eine Auswahl in einen Pfad umzuwandeln,
● eine Schnellmaske zur Bearbeitung der aktiven Auswahl zu generieren (analog zum
Bildfenster).
Einführung in GIMP
(GNU Image Manipulation Program)
Die GIMP - Menüs (4)
G.Hessler, Rechenzentrum
Gerd Hessler
Ansicht-Menü
●
●
●
●
●
●
neue Ansicht: zusätzliche Bildfenster (z.B. für Vergrößerungen keine vollst. Bildkopie mit Werkzeugen)
Vergrößerung: stufenweise anpassen (s.a. Navigationsfenster)
festgelegt und
Bild an Fenster u. Fenster an Bild
(s.a.Werkzeugfenster) oder Vollbild anpassen,
Ansichtsfilter Farbkorrekturen
( Sehschwächen),
div. Arbeitshilfen werden konfiguriert (Lineale, Hilfslinien, Raster,
Rahmenfarbe => Rand einer Vorlage). Einstellungen hierzu auch
im Bild Menü.
einige Layouteinstellungen werden
eingerichtet.
Einführung in GIMP
(GNU Image Manipulation Program)
G.Hessler, Rechenzentrum
Gerd Hessler
Die GIMP - Menüs (5)
Bild-Menü:
●
●
●
●
●
●
●
●
●
●
Bild-Fenster duplizieren (vollst. Kopie
zur Bearbeitung mit allen Ebenen),
Farbmodi ändern (RGB, Graustufe,
indiziert => kein CMYK in Gimp!),
Transformationen durchführen,
Leinwandgröße => sichtbare Zeichenfläche und nicht den Bildinhalt vergrößern oder verkleinern,
Druckgröße (Bildgröße) alternativ zum
Druckmenü festlegen
Bild-Skalierung (nicht interaktiv)
durchführen,
Bild automatisch zuschneiden,
Ebenen vereinen,
Hilfslinien und Gitter einstellen
Bildeigenschaften anzeigen.
Einführung in GIMP
(GNU Image Manipulation Program)
Die GIMP - Menüs (6)
G.Hessler, Rechenzentrum
Gerd Hessler
Ebenen-Menü
Über das Menü Ebene können analog zum Ebene Dialogfenster:
●
●
●
●
●
Ebenen editiert (einfügen, duplizieren, vereinen und löschen),
Ebenen-Reihenfolgen (Stapel) geändert,
Ebenen-Masken erstellt,
Ebenen zugeschnitten und vereint
und
Ebenentransformationen (Spiegeln etc.) durchgeführt werden
Einführung in GIMP
(GNU Image Manipulation Program)
Die GIMP - Menüs (6a)
Füllen mit schwarzer Farbe macht
eine Ebene transparent,
weiße Bereiche
der Ebene sind
nicht ausgeblendet !
G.Hessler, Rechenzentrum
Gerd Hessler
Ebenen-Masken
Über das Menü Ebene oder das
Kontextmenü der Ebenenpalette
können Ebenen-Masken erstellt
werden.
Über eine Maske wird ein Auswahlbereich durch Übermalen generiert.
Somit können Bereiche ausgefiltert,
bearbeitet und nachfolgend auf die
Ebene angewendet werden!),
Ebenenpalette
Kontextmenü
Ebenenpalette
Einführung in GIMP
(GNU Image Manipulation Program)
Die GIMP - Menüs (7)
G.Hessler, Rechenzentrum
Gerd Hessler
Farben-Menü
(nur neuere Versionen)
Alle Anpassungen können objektiv
über Skalen oder Histogramme bzw.
intuitiv über Vorschaufenster erfolgen.
Das Farben-Menü beinhaltet:
●
●
●
●
●
●
●
●
Farbabgleiche (CMY,RGB),
Farbton/Sättigung (Farben durch
anderen Farben ersetzen, Helligkeit, Sättigung des Gesamtbildes
oder einzelner Farben ändern,
Einfärben Bild wird je nach gewähltem Farbton (RGB) eingefärbt,
Helligkeit- und Kontraständerungen
S/W- Schwellwerteinstellungen,
Farbwerte- u. Farbkurvenkorrektur,
Posterisierungen (Farbreduktion)
diverse weitere Farbfilterungen
GEGL => ab GIMP 3 geplante 32 bit
Bildbearbeitung
Einführung in GIMP
(GNU Image Manipulation Program)
Die GIMP - Menüs (7a)
G.Hessler, Rechenzentrum
Gerd Hessler
Farben-Menü: Wertekorrektur
Die Farbwertekorrektur kann zur Aufhellung
bzw. der Abdunklung von Bildern genutzt werden. Durch Spreizung der Graustufenskala
eines Bildes wird eine Kontrastverstärkung
erreicht. Durch analoges Bearbeiten der Farbkanäle können Farbstiche entfernt werden.
Eine feinere Korrektur kann über die interaktiv
anpaßbare Farbkurve erfolgen. Hier können
einzelne Werte- oder Farbbereich (Graustufe,
Farbe) aufgehellt oder abgedunkelt werden.
Einführung in GIMP
(GNU Image Manipulation Program)
G.Hessler, Rechenzentrum
Gerd Hessler
Die GIMP - Menüs (8)
Werkzeug-Menü
beinhaltet alle Werkzeuge des GimpWerkzeugfensters:
●
Bereichs- und Farbauswahl,
●
Mal- und Pfadwerkzeug,
●
Transformation,
●
Anpassungen,
●
Bemaßung,
●
Text.
Einführung in GIMP
(GNU Image Manipulation Program)
Die GIMP - Menüs (9)
G.Hessler, Rechenzentrum
Gerd Hessler
Dialog-Menü
(nur bei älteren Versionen):
beinhaltet alle Konfigurations- und Einstellungswerkzeuge, die als separates
Fenster aktiviert oder als Register in das
Registerfenster integriert werden können.
In neueren Versionen werden diese über
das Fenster-Menü => andockbare Dialoge aufgerufen.
Einführung in GIMP
(GNU Image Manipulation Program)
Die GIMP - Menüs (10)
G.Hessler, Rechenzentrum
Gerd Hessler
Filter-Menü
listet alle unter Gimp verfügbaren Filter
zur Bildmanipulation auf. Alle Filter
sind in Kategorien (Weichzeichner,
Verbessern, Rauschen, Licht, Verzerren und Kunstfilter u.a.) untergliedert.
Nützliche Filter zur Bildbearbeitung
findet man in der Rubrik Verbessern.
Verfremdungseffekte sind unter Verzerren, Rauschen oder Künstlerisch
zusammengefaßt.
Hinweis: Je nach Filter und Bildauflösung werden rechenintensive Operationen durchgeführt.
Einführung in GIMP
(GNU Image Manipulation Program)
Die GIMP - Menüs (10a)
G.Hessler, Rechenzentrum
Gerd Hessler
Filter-Menü Beispiele
Kratzer =>
Verbessern =>
Flecken entfernen
=> Schwellwert
Weiß verändern
Bewegungsunschärfe => Bildbereich auswählen => Weichzeichnen
=> Bewegungsunschärfe
Einführung in GIMP
(GNU Image Manipulation Program)
G.Hessler, Rechenzentrum
Gerd Hessler
Die GIMP - Menüs (10b)
Filter-Menü Beispiele
Verzerren => Einrollen
Verzerren => Relief
Licht und Schatten => Lichteffekte
Rauschen => Verstreuen
Einführung in GIMP
(GNU Image Manipulation Program)
Die GIMP - Menüs (10c)
Künstlerisch => Ölgemälde
Dekoration => Altes Foto
G.Hessler, Rechenzentrum
Gerd Hessler
Filter-Menü (Beispiele)
Abbilden => kleine Kacheln
Einführung in GIMP
(GNU Image Manipulation Program)
Die GIMP - Menüs (11)
G.Hessler, Rechenzentrum
Gerd Hessler
Scripte-Menü
(nur bei älteren Versionen):
beinhaltet, in Kategorien unterteilt,
Zusatzfilter (Scripte). Dies sind von
Anwendern erstellte Filter, die in
Gimp integriert wurden (s.a. Menü
Xtns).
In neueren Versionen wurden diese
teilweise ins Filtermenü verschoben.
Einführung in GIMP
(GNU Image Manipulation Program)
Die GIMP - Menüs (12)
G.Hessler, Rechenzentrum
Gerd Hessler
Fenster-Menü:
aktiviert analog zum „alten“
Dialog-Menü alle Konfigurations- und Einstellungswerkzeuge, die
als separates Fenster geöffnet oder
als Register in ein bestehendes Registerfenster
gruppiert werden.
Einführung in GIMP
(GNU Image Manipulation Program)
Die GIMP - Menüs (13)
G.Hessler, Rechenzentrum
Gerd Hessler
Gimp – Hilfen
Über das Menü: Hilfe des Gimp-Hauptfensters kann eine umfangreiche online-Hilfe
eingesehen werden. Gezielt kann nach Aktivieren der Kontexthilfe auch direkt auf
ein Werkzeug geklickt werden.
Die online-Hilfe kann zusätzlich lokal installiert werden und wird auf den Seiten
der Gimp-Distributoren bereitgestellt. Alternativ kann auf die online-Hilfe auch über
das Internet zugegriffen werden.
Gimp Verfügbarkeit und weitere Informationen
Das Bildmanipulationsprogramm Gimp muß auf Windows-Rechner zusätzlich
installiert werden. Unter LINUX/UNIX gehört es meist zum Lieferumfang.
Nähere Informationen zum Produkt und zum Download über diverse regionale Distributoren erhält man unter:
http://www.gimp.org
Für vielfältige nützliche Tipps ist folgende Adresse empfehlenswert:
http://www.gimpusers.de
Document
Kategorie
Internet
Seitenansichten
2
Dateigröße
4 426 KB
Tags
1/--Seiten
melden