close

Anmelden

Neues Passwort anfordern?

Anmeldung mit OpenID

Ergänzungshandbuch

EinbettenHerunterladen
Ergänzungshandbuch
BobCAD Version 18.0
Deutsch
© BobCAD-CAM, Inc.
1
BOBCAD Version 18.0 Verbesserungen
Als bisherige Kunden müssen Sie das lesen!!!
Dies ist das Handbuch für Kunden, die sich von früheren Versionen zu Version 18.0
verbessern.
Version 18.0 ist die bedeutenste Verbesserung von BOBCAD-CAM. Verglichen mit
vorherigen Verbesserungen, gibt es bei dieser mehr als 5 x so viele neue Eigenschaften.
Es ist eine umfangreiche Aktualisierung des Codes, um neue Entwicklungen in Fenstern,
neue Eigenschaften, wie mehrfache Fenster und neue Skripts für zukünftige
Entwicklungen zu unterstützen.
Erstens: Entfernen Sie nicht Ihre gegenwärtige Version von BOBCAD. Es wird einige
Stunden dauern bis Sie mit den Änderungen von Version 18.0 zurecht kommen werden.
Behalten Sie die frühere Version, um inzwischen Teile zu programmieren. BOBCAD
Programme nehmen nicht viel Speicherplatz ein, so dass es wirklich nicht nötig ist, die
frühere Version zu deinstallieren.
Zusätzlich zu all den neuen Funktionen gibt es mehrere Änderungen, die Sie als ein
erfahrener BOBCAD-Nutzer erst wissen müssen. Fahren Sie auf den nächsten Seiten fort,
um diese zu erlernen.
Wir empfehlen, dass Sie einen großen Monitor, minimal 17 Zoll
benutzen. BOBCAD 18.0 gestattet es sowohl verschiedene Fenster zu
öffnen, als auch viele Werkzeugleisten zu nutzen. Alle diese
Möglichkeiten passen nicht auf einen kleinen Monitor. Einen 17“
Monitor können Sie jetzt für weniger als 200,- kaufen.
Manche der neuen Eigenschaften werden nicht in diesem Nachtrag dokumentiert, da sie
selbsterklärend sind. Diese schließen lange Dateinamen, ausgedehnten IGES und DXF
Unterstützung, Unsichtbarkeit von Farben usw. ein.
Zukünftig werden Verbesserungen unserer Handbücher auch auf unseren Web-Seiten
veröffentlicht. Unsere Web-Seiten werden laufend aktualisiert, so dass sie neue Hilfen,
interessante Informationen, Quellen neuer Skriptdateien und NC-Konfigurationsdateien
erhalten. Ich empfehle, dass Sie unsere Web-Seiten regelmäßig besuchen.
Wenn Sie dieses Handbuch von unserer Web-Seite heruntergeladen haben, kann es sein,
dass Sie dieses Handbuch wieder indizieren müssen. Verschiedene Versionen von
Microsoft Word können das Handbuch verkürzen oder verlängern und das
Inhaltsverzeichnis zu Beginn und das Stichwortverzeichnis am Ende verändern. Um das
Stichwortverzeichnis wieder zu indizieren gehen sie zum Ende des Handbuchs und
klicken darauf. Danach wählen Sie in Microsoft Word Funktion: Index und
Verzeichnisse. In dem Dialog finden Sie die Funktion Formate und die Option
2
Aufzählung. Klicken Sie danach auf den OK Button. Das Handbuch wird jetzt wieder
indiziert. Sie müssen das ganze Stichwortverzeichnis wieder wählen und klicken auf den
Unterstreichungsknopf, um die Unterstreichung zu entfernen. Sie können auch die
Schriftgröße auf '12' setzen. Tun Sie danach dasselbe mit dem Inhaltsverzeichnis am
Anfang vom Handbuch, aber jetzt wählen Sie Menü Einfügen: Index und Verzeichnisse,
Inhaltsverzeichnis aus.
3
Inhaltsverzeichnis
(Stichwortverzeichnis am Ende)
STARTEN EINER NEUEN ZEICHNUNG ODER MEHRERER
ZEICHNUNGEN .......................................................................................... 5
AUSWAHLMODUS: DAS ZEICHNUNGSFELD.................................... 7
VERSCHIEDENE ANSICHTEN DESSELBEN TEILES ..................... 11
EIGENSCHAFTEN SETZEN................................................................... 12
ICONS UND WERKZEUGKÄSTEN....................................................... 15
ANSICHTSOPTIONEN............................................................................. 17
AUFRÄUMEN DER ZEICHNUNG ......................................................... 18
BEMAßUNG UND TEXT.......................................................................... 19
BEMAßUNGSÄNDERUNG, ÄNDERUNG VON ELEMENTEN ........ 20
TEXT ENTLANG EINES PFADES ......................................................... 23
BENUTZERKOORDINATENSYSTEME (USER COORDINATE
SYSTEM - UCS) FÜR DIE 3-D KONSTRUKTION ............................. 25
UMWANDELN UND ANORDNEN ......................................................... 27
OBERFLÄCHEN-FUNKTION UND 3-D OBERFLÄCHEN ............... 28
PROJEKTION AUF EINE OBERFLÄCHE........................................... 34
NC CAM ...................................................................................................... 38
VISUAL BASIC SKRIPTE SCHREIBEN............................................... 46
INDEX.......................................................................................................... 47
4
Starten einer neuen Zeichnung oder mehrerer Zeichnungen
BOBCAD 18.0 erlaubt sowohl das gleichzeitige Öffnen mehrerer Zeichnungen als auch
mehrfache Ansichten desselben Teils.
Wenn Sie BOBCAD das erste Mal starten, eröffnet sich das nachfolgende Fenster.
Nun gehen Sie auf das Menü File und
wählen die Funktion New. Das
nebenstehende Menü offnet sich. Wählen
Sie Type; Drawing, based on; normal (wie
hier zu sehen)
Jetzt klicken Sie OK und Ihre erste
Zeichnung erscheint.
In früheren Versionen mussten Sie, wenn Sie eine neue Zeichnung öffnen wollten, die
5
bestehende Zeichnung zuerst schließen. Sie konnten nur jeweils eine Zeichnung öffnen.
In Version 18.0 ist dies nicht der Fall. Version 18.0 unterstützt mehrere Fenster. Auf
diese Art können Sie jederzeit mehrere Zeichnungen geöffnet haben. Wenn Sie eine neue
Zeichnung starten, werden Zeichnungen, die schon offen sind, nicht automatisch
geschlossen.
Um eine Zeichnung zu schließen, wählen Sie Funktion Close. Um alle Zeichnungen
anzuzeigen, mit denen Sie gegenwärtig arbeiten, gehen Sie auf das Menü Window und
wählen die Funktionen Tile oder Cascade aus.
Das Starten von BOBCAD von Windows Explorer oder von anderen
Applikationen
BOBCAD kann durch das direkte anklicken einer BOBCAD-Zeichnungdatei direkt vom
Windows Explorer gestartet werden. Jede Datei mit dem BOBCAD-Logo wird
BOBCAD starten.
6
Auswahlmodus: Das Zeichnungsfeld
BOBCAD 18.0 unterstützt den aktiven Auswahlmodus. Dies bedeutet, dass Sie immer im
Auswahlmodus sind, es sei denn, Sie führen eine bestimmte Funktion aus. Dies wird
durch den Text in der unteren linken Ecke des Bildschirms (Selection mode) angezeigt.
Dies erlaubt Ihnen, die Elemente viel leichter und schneller auszuwählen. Zeichnen Sie
zuerst ein Rechteck. Als nächstes ziehen Sie einen Rahmen, unten festhalten der linken
Maustaste, um die Elemente und lassen dann die linke Maustaste los. Das markiert
automatisch alle Elemente innerhalb des Rahmens.
Anmerkung: Diese neue Methode werden BOBCAD-Nutzer anwenden. Sobald Sie
jedoch eine Blockierung im Programm haben, ist es leichter und schneller wie vorher zu
arbeiten.
7
Für die Auswahl ziehen Sie mit der Maus einen Rahmen um die Einzeiheit.
Die ausgewählten Elemente werden in der Mitte mit einem Pfeil gekenzeichnet, um die
Bearbeitungsrichtung für NC CAM zu zeigen. (Dies kann in NC CAM geändert werden).
Im Menü Special kann mit der Funktion Extra: Selection die Richtung umgekehrt
werden.
Auswahl eines Elements
Während des Auswahlmodus wird der Cursor nahe eines Elementes bewegt und dieses
ausgewählt. Das Element wird rot (oder eine andere Auswahlfarbe, wird mit dem Menü
Change: Color Setup festgelegt), und ein Richtungspfeil erscheint in seiner Mitte. Wenn
Sie jetzt eine anderes Element auswählen, wird das erste Element deaktiviert.
Um eine weiteres Element zu markieren, ohne schon zu deaktivieren, halten Sie das
markierte Element mit der Ctrl-Taste (Strg-Taste) auf Ihrer Tastatur.
8
Auswahl einer Kette
Bringen Sie den Cursor nahe an das Ende eines Elementes, das Teil einer Kette ist
während Sie die Umschalttaste drücken, betätigen Sie die linke Maustaste und ziehen
einen Rahmen. Die ganze Kette ist gewählt. Anmerkung: wo Sie das Element markieren
bestimmt die Richtung.
Beispiel für die Geschwindigkeit und Benutzerfreundlichkeit, Nutzen
der neuen Auswahlmethode
Im Menü Datei: Environment:
Defaults Auswahl Option Auto
peselect ein.
Im Menü Dimension den
Menüpunkt Text wählen. Schreiben
Sie als Text ‘Very Fast’, wie Sie
hier sehen. Nutzen Sie ‘Times New
Roman’ Schrift, Option Bold
aktivieren, Textheight auf 1.0
setzen. Die Option Drag text
ausschalten.
Jetzt OK Klicken und der Text
erscheint so wie Sie Ihn hier sehen.
Auswahlfunktion Views: View All um die Ansicht des Texts zu vergrößern. (dies
verbessert die Qualität des Ergebnisses der nächsten Funktion).
Wählen Sie die Funktion: Dimensions Vectorize Text. Stellen Sie die Genauigkeit auf
0,000005 und Klicken OK. Der Text ist jetzt in Linien und Bögen umgewandelt worden,
die für die maschinelle Fertigung verwendet werden können
9
Zeichnen Sie ein Rechteck mit den hier
angegebenen Werten um das Dargestellte.
Weil die Option Auto preselect vorher im
Menü Datei Environment Defaults ;
gewählt wurde, sind alle Elemente schon
gewählt. Wenn sie noch nicht gewählt
wurden, wählen Sie sie jetzt durch ziehen
eines Cursor-Rahmens um sie herum.
Jetzt wählen Sie die Funktion: Other:
Pocket: Spiral und setzen die Parameter
wie hier zu sehen und klicken OK.
Als ein Ergebnis haben Sie jetzt einen
Pfad um den Text geschaffen, der eine
herausgehobe Figur ist.
Als letzten Schritt können wir jetzt wie
folgt in einen NC-Code umwandeln.
Im Menü Special Menüfunktion Insert NC anwählen und OK anklicken. Weiter im Menü
Special Menüfunktion Generate NC auswählen. Der NC-Code wird automatisch für die
herausgehobene Figur erzeugt.
10
Verschiedene Ansichten desselben Teiles
Um 2 oder mehr Ansichten vom selben Teil zu erhalten, wählen Sie die Funktion
Window: New
Als erstes befindet sich das neue Fenster im Vordergrund. Um mehrere Fenster simultan
zu betrachten, wählen Sie die Funktions Window: Tile.
Hier ist ein Beispiel von zwei Ansichten des gleichen Teiles.
Sie können 2 oder mehr Ansichten des gleichen Teiles gleichzeitig nutzen.
In einer Ansicht vorgenommene Änderungen zeigen sich auch in der anderen Ansicht.
Klicken Sie in eine der Ansichten, und Sie sehen, dass die Titelleiste des aktuellen
Fensters blau wird. Dies zeigt an, dass dies jetzt die aktive Ansicht ist. Zum Beispiel
wenn Sie jetzt das Menü: Views: und Funktion: View All wählen, wird nur die aktive
Ansicht neu gezeichnet.
11
Eigenschaften setzen
Version 18.0 erlaubt dem Benutzer, die
Umgebungsparameter (Eigenschaften)
zu wechseln. Diese beeinflussen die
Benutzerschnittstelle bei der
Zeichnungserstellung. Wählen Sie
Funktion: File: Environment und Sie
sehen den nebenstehenden Dialog.
Die Titel auf Oberseite des Dialogs
werden „Registerkarte“ genannt. Hier
zeigen wir die verschiedenen
Registerkarten mit
Herstellereinstellungen, die den früheren
BOBCAD-Versionen ähnlich sind.
Um gewohnheitsmäßig zu speichern, muss die Funktion Autosave Defaults aus sein.
Auf der Registerkarte Snap Points sind
die dargestellten Optionen. Ich ziehe es
vor, BOBCAD mit den Einstellungen,
wie hier dargestellt zu benutzen.
Unten ist ein Beispiel dafür, wie diese
genutzt werden können. Zuerst
zeichnete ich die waagerechte Linie
„A“. Als nächstes zeichne ich mit dem
Befehl Arc: Snap Center: an jedem
Ende und in der Mitte der Linie einen
Kreis. Danach zeichnete ich den Punkt
mit Hilfe der Funktion Point: Sketch.
Danach zeichne ich mit Hilfe der
Funktion Line: Join die um 45 Grad nach
rechts abgewinkelte Linie „B“.
12
In vorherigen Versionen mussten
Sie zuerst Punkte an den Enden
zeichnen, dann Mittelpunkt usw. .
In der Registerkarte General setzen
Sie für den Punktabstand (Pick
distance) den Abstand von 0,4 ein .
Dies ist derAbstand in welchem
BOBCAD ein Element oder das
Ende eines Elementes fängt. Wenn
der Cursor außerhalb dieses
Abstandes ist, fängt er die Elemente
nicht. Die Minimalgröße des
Auswahlabstands ist 0,04 inch.
BOBCAD speichert die Zeichnung
automatisch in den angegebenen
Intervallen. Wenn Sie BOBCAD durch einen Abbruch beenden, ohne das gespeichert
wurde, so können Sie die Zeichnung mit der zuletzt automatisch gespeicherten Version
wiederherstellen.
Das Raster Grid Tab legt ein Gitter auf den Bildschirm, der Ihnen erlaubt, Koordinaten so
zu fangen als ob Sie einen Tabulator eingesetzen würden. Dies beeinflusst solche
Funktionen wie Point: Sketch, Line: Sketch, Arc: Sketch, Line: Continuous: Join .
13
In der Registerkarte Screen können Sie die Tooltips-Option einschalten. Mit Tooltips
erhalten Sie Information über die Abstände des Cursor zu einem Element. Die Größe der
Abstände ist in der angegebenen Tabelle angezeigt.
sehen.
Das Achsenobjekt ist das
Objekt, das erscheint, wenn Sie
eine Gruppe schaffen. Die
Gruppenfunktion, die Sie im
Menü Change finden, fasst eine
Anzahl von gewählten
Elementen zu einem einzelnen
Objekt zusammen. Das einzelne
Objekt kann dann leicht
manipuliert werden, wie mit
Kopieren, Drehen, Unsichtbar
usw.. Die Richtung und der
Ursprung des Objekts wird von
seinem Achsenkreuz
dargestellt. Jede Gruppe hat
eines, wie in der Darstellung zu
Für Informationen über die Werkzeugkästen gehen Sie zur nächsten Seite.
14
Icons und Werkzeugkästen
BOBCAD 18.0 ermöglicht es Ihnen Werkzeugkästen maßgeschneidet zu entwickeln und
einzubauen. Gehen Sie in das Menü File: Environment und Sie werden dort die
folgenden Registerkarten sehen.
Wählen Sie die Registerkarte
Toolbars und markieren Sie
den Werkzeugkästen so, wie
auf dem Bildschirm zu sehen.
15
Werkzeugkästen können folgendermaßen geändert und plaziert werden (Das sind
Standardfunktionen von Windows).
Schritt 1: Ziehen Sie die Werkzeugleiste zur Seite und docken Sie diese durch Ergreifen
der Oberseite der Werkzeugleiste an. Sobald Sie die Werkzeugleiste nahe den Seiten
Ihres Bildschirms bewegen, wird die Werkzeugleiste senkrecht (einspaltig) oder
waagerecht (einzelne Reihe). Dann wissen Sie, dass sie angedockt ist.
Schritt 2: Um die Werkzeugleisten zu entkoppeln, ergreifen Sie die zwei parallelen
Linien (siehe Bild) und bewegen sie weg.
Schritt 3: Um die Werkzeugleiste anzupassen, klicken Sie doppelt in einem leeren
Abschnitt der Werkzeugleiste und der folgende Dialog erscheint:
Die rechte Seite zeigt die Icons, die gegenwärtig in der Werkzeugleiste sind. Die linke
Seite zeigt Icons, die hinzugefügt werden können. Klicken Sie auf eines der Icons im
linken oder rechten Fenster, um diese Icons hinzuzufügen oder zu entfernen. (Die
Werkzeugleiste auf Ihrem Bildschirm wird während Sie das tun die Änderungen sofort
ausführen)
16
Ansichtsoptionen
Zusätzlich zu mehrfachen Ansichten gibt es mehrere neue Besichtigungsoptionen.
Diese beinhalten das dynamische Drehen, Dynamische Umschalten und das dynamische
Skalieren. Die meisten von diesen sind selbsterklärend. Sie werden die dazugehörigen
Icons auch in der Werkzeugleiste finden.
Ein Klick der linken Maustaste auf dem Koordinatenkreuz und es öffnet sich der 3-DAnsichtdialog, wie zusehen.
17
Aufräumen der Zeichnung
Im Menü Change finden Sie eine Funktion Reorganize (Reorganisieren), welche von
doppelten Elementen befreit und unterbrochene Elementen in Ordnung bringt.
Markieren Sie zuerst die Elemente, die Sie mit Hilfe des Prüfens bereinigen wollen:
Wählen Sie Edit : Select Entities . Danach verwenden Sie die reorganize-Funktion, um
von Doppelungen zu bereinigen.
Dies kann in einer Anzahl von Situationen sehr nützlich sein.
Wenn die Zeichnung gut aussieht, aber die CAM-Funktion sich nicht fortsetzen lässt,
kann dies unter anderem von identischen Elementen verursacht werden. Solch ein
Element kann schwer zu finden sein. Durch die reorganize-Funktion befreit man die
Zeichnung von diesen Doppelungen.
Ein anderes Beispiel ist, wenn eine mit Corel Draw gezeichnete DXF-Datei gelesen wird.
Wenn sie starke bzw. breite Linienarten bei Corel Ziehung verwenden, werden diese als
doppelte Linien in DXF-Dateien gespeichert. Obwohl es sein kann, dass die Zeichnung
perfekt aussieht, nachdem sie in BOBCAD gelesen worden ist, sehen Sie, dass die
Zeichnung zweimal gezeichnet wurde. Dies verursacht bei der maschinellen Erstellung
Probleme, wenn nicht zuerst bereinigt wird.
18
Bemaßung und Text
Version 18.0 hat noch viel mehr Möglichkeiten, die sich auf Bemaßung und Text
beziehen.
Zusätzlich zu Koordinatenbemaßung und der automatischer Bemaßung können Sie die
Funktion Change: Attributes verwenden, um eine Vielfalt von Attributen für Bemassung
und Text festzulegen.
Hier sehen Sie ein Beispiel mit
Toleranzangaben.
die Attribute jetzt ungenutzte Attribute.
Wenn Sie zuerst die Elementund dann die Attribut-Funktion
wählen, dann ändern Sie nur
die Attribute der gewählten
Elemente. Wenn vorher kein
Element gewählt wurde, sind
Ein schneller Weg ist, auf dem Element der Klick auf die rechte Maustaste und die
Auswahl der Funktion Attributes vom auftauchenden Menü.
19
Bemaßungsänderung, Änderung von Elementen
Zeichnen Sie eine Bemaßung. Jetzt bewegen Sie den Cursor auf Oberseite der Bemaßung
und klicken rechts Ihre Maus. Wählen Sie aus dem Menü Attributes. Sie finden jetzt
zahlreiche Attribute, die geändert werden können.
Eine andere Art, wie eine Bemaßung
modifiziert werden kann, anklicken von
Modify icon von der Werkzeugleiste.
Als Nächstes markieren Sie die
Bemaßung die Sie wünschen und
halten die linke Maustaste
gedrückt. Sie werden sehen, ein
kleiner Kreis erscheint im
Zentrum des Bogens oder der
Linie auf das sich die Bemaßung
bezieht. Bringen Sie Ihren
Cursor durch die Mitte des
kleinen Kreises und eine neue
Bemaßung entsteht. Im Falle von
einem Radius kann die
Bemaßung ein Durchmesser werden. Ziehen Sie den Cursor wieder durch den kleinen
Kreis ändert sie sich nach senkrecht.
20
Wenn Sie auf das Modify Icon klicken ändert sich der Cursor zum
Änderungscursor. Dieser Cursor kann mehrere Dinge.
Bewegt sich der Änderungscursor zu
einer Linie und wird ein
Doppelklick auf der Linie
ausgeführt, erscheint das folgende
Menü mit dem sich die Linie prüfen
lässt.
Bewegt man den Änderungscursor zu
einem Bogen und führt man einen
Doppelklick auf dem Bogen aus, so
erscheint der folgende Dialog mit dem
man den Bogen prüfen kann.
Bewegt man den
Änderungscursor zur
Bemaßung und führt
den Doppelklick aus, so
erscheint der folgende
Dialog mit dem man die
Bemaßung prüfen kann.
21
Bewegt man den Änderungscursor zu einem
Text und führt man einen Doppelklick aus,
so erscheint der folgende Dialog mit dem
man den Text prüfen kann.
Sie können sogar den Text selbst ändern.
Statt den Änderungscursor zu verwenden, können Sie auch auf einem Element die rechte
Maustaste betätigen und auf dem sich automatisch öffnenden Menü die Menüfunktion
Modify nutzen.
22
Text entlang eines Pfades
Zeichnen Sie Text mit Hilfe des Menüs Dimensions: Funktion: Text. Zeichnen Sie jetzt
eine Kurve, die der Pfad wird, dem Sie folgen wollen. Klicken Sie den Text an und
danach während Sie die Umschalttaste halten, die Kurve. Wählen Sie danach Funktion:
Dimensions Fit Text to Path.
Hier ist ein Beispiel:
Es gibt mehrere Dinge, die Sie über diese Funktion wissen müssen.
Hier ist ein Beispiel:
1)
True type-Schriftarten lassen sich nicht sehr gut skalieren. Wenn Sie den Text
skalieren und er sich nicht an die Kurve anpasst, können Sie diese Funktion wie folgt
wiederholen: Klicken Sie den Text, der jetzt entlang der Kurve liegt an. Als Nächstes
klicken Sie die Kurve an und verwenden die Funktion: Dimensions: Fit Text to Path
erneut.
23
2) Um Text für das Gravieren vorzubereiten nutzen Sie die Funktion: Vectorize Text.
Sobald der Text vektorisiert ist, besteht er aus vielen kleinen Elementen (Linien und
Bögen), die jetzt maschinell hergestellt werden können. Vektorisierter Text ist
normalerweise skaliert.
Anmerkung: Funktion Smash text (Zerschlagen Text) wird jetzt Vectorize Text
genannt und befindet sich im Menü Dimensions.
24
Benutzerkoordinatensysteme (User Coordinate System - UCS) für die
3-D Konstruktion
In Version 18.0 können Sie ein Koordinatensystem nutzen, welches relativ zu den
Bildschirmachsen liegt. Wir nennen das Benutzerkoordinatensystem oder UCS. Es wird
hier als das dreifache Pfeilobjekt gezeigt. Der einfache Pfeil ist die X-Richtung, der
doppelte Pfeil die Y-Richtung, der dreifache Pfeil die Z-Richtung. Die Größe des UCS
kann im Menü File: Environment: Registerkarte Screen unter Axis Size eingestellt
werden.
Das UCS kann bewegt und gedreht werden. Dies ist für die 3-D Konstruktion sehr
nützlich. Klicken Sie rechts auf das UCS, und das oben dargestellte Menü öffnet sich.
25
Im obengenannten Beispiel verwendete ich Option „Snap to“ folgendermaßen, bei 3 D
ausrichten lege ich das UCS in die Ecke des Objektes. Dies erlaubte mir, das leichte
drehen des Objektes. (In früheren Versionen von BOBCAD musste ich die Seite des
Objektes parallel zu meiner Bildschirmachse haben, um es anschließend zu drehen.)
Das UCS kann auch bewegt werden, um den NC Code von einem anderen Startpunkt
(Ursprung) zu generieren. In früheren Versionen war dies Funktion “New Zero At“ im
NC-CAM Menü.
26
Umwandeln und Anordnen
Eine neu hinzugekommene Funktion ist die Funktion Translate (Umwandeln). Klicken
Sie einige Elemente an. Als nächstes nutzen Sie das Menü Change: Translate. Und
wählen die Option Make copy. Setzen Sie die Anzahl der Kopien auf 1.
Als nächstes klicken Sie auf Drag. Ein Dialog Transform, erscheint wie auf dem
Bildschirm zu sehen. Wählen Sie das links liegende Icon. Stellen Sie die Kopie jetzt
durch ziehen des gewählten Objektes zu einem neuen Standort her und klick auf die linke
Maustaste. Nachdem die Kopie erstellt worden ist, können Sie diese um den Cursor
drehen.
Die Einstellung „Rotate after Move“ bleibt, bis Sie diese durch einen Klick darauf
ausschalten. Die anderen Symbole ermöglichen das Drehen und Spiegeln.
27
Oberflächen-Funktion und 3-D Oberflächen
Die Version 18.0 hat die Schnittstelle, um eine Oberfläche zu schaffen. Die Oberfläche
hat sich bedeutend verändert. Es ist leicht, Änderungen zu schaffen und vorzunehmen,
wenn das Ergebnis nicht wie gewünscht ist. Außerdem schließen die neuen Merkmale
folgendes ein:
1)
2)
3)
4)
die Fähigkeit, eine unterschiedliche Anzahl von Elementen in Pfaden anzuordnen
Unterschneidungen
5 Achsen Ausgabe
Spiralförmige Schneidbahnen
Wie arbeitet das neue Oberflächeninterface:
In der obengenannten
Zeichnung haben wir ein
Drahtgitter mit 2 Kurven
gezeichnet. Einen Satz, den
wir auf einen Layer
„Paths“, den Anderen
setzten wir auf den Layer
der „Sections“ genannt
wurde. Dies ist nicht mit
der Version 17.0
vergleichbar.
28
Als Nächstes wird der Layer “Sections” sichtbar. Danach wird chain (Kette) in der
Reihenfolge von nahe bis weit, wie hier gezeigt ausgewählt.
Danach wählen Sie im Menü 3-D Set Path und setzen Sie die hier gezeigten Werte ein.
Dies setzt die Pfadparameter so, wie sie die
Oberflächenfunktion verlangt. Nachdem die
Pfadparameter gesetzt sind, wird dies von
einem Zeichen im 3-D Menü vor der
Funktion „Set path“ angezeigt. Führen Sie
die Pfadfunktion wie hier gezeigt aus.
Als Nächstes machen Sie die Elemente des Layers “path”
sichtbar und die Elemente des Layers „Sections“ unsichtbar.
Verketten Sie jetzt, wählen Sie die Elemente auf dem Layer
„Sections” in der Richtung und Folge wie hier gezeigt. Die
Version 18.0 lässt Sie Ketten wählen und mit der Funktion
„Edit“ verändern. Wählen Sie die Elemente wie folgt aus:
Bewegen Sie den Cursor, der nahe bei dem entfernten Ende der
Kette liegt und betätigen die Umschalttaste sowie die linke
Maustaste. Die ganze Kette ist gewählt.
Danach wählen Sie im
Menü 3-D die Funktion
Skin (Oberfläche). Setzen
der Parameter im SkinMenü (Oberflächenmenü)
und die Oberfläche ist
generiert.
29
Wenn das Ergebnis nicht
gewünscht wird, können
Sie die Funktion undo
wählen. Die Abschnitte
sind weiterhin ausgewählt
und die
Oberflächenfunktion kann
wieder aufgerufen werden
sowie die Parameter für
ein anderes Ergebnis
geändert werden.
Hier ist ein spiralförmiger Bearbeitungsablauf aus demselben Gittermodell generiert
worden. Sie finden die spiralförmige Option im Skin-Menü.
Anmerkung: Wenn die Zeichnung nur aus Teilen besteht, dann muss Funktion Set Path
vor dem Markieren der Abschnitte und dem Aufrufen der Funktion Skin ausgeführt
werden.
30
Ausgleichen. Diese Funktion (Equalize) gleicht die Anzahl der Elemente in den
ausgewählten Kurven aus. Während die Anzahl der Elemente für die gewählte Kurve
gleich sein muß, trifft das nicht für den Pfad zu.
Automatisches Ausräumen anpassen .. In Version 18.0 wird die
Oberflächenfunktion eigenständig abgearbeitet. Sie brauchen nicht die Radien in den
Kurven gleichgroß oder größer als den Werkzeugradius zu wählen.
Beispiel für ein Oberflächenteil ohne Pfade
Im obengenannten Teil haben wir nur Abschnitte und keine Pfade.
Auswahl der Funktion 3-D: Set path und
geben Sie die Parameter ein , um von der
Oberflächenfunktion so verwendet zu
werden, als ob Sie gerade Linienpfade hätten,
welche die Abschnitte verbinden.
Nun verwenden Sie die Verkettung mit der
ausgewählten Funktion und teilen beide
Abschnitte ein. Als Nächstes wählen Sie die Funktion 3-D: Skin und setzen die
Paramenter. Die entstehende Oberfläche wird unten gezeigt.
31
Sie brauchen keine Radien, wenn Sie die Funktion “Automatic removal of undercutting”
im Oberflächenmenü (Skin) verwenden.
32
Mehr über die Oberfächen: Rendering (Darstellung)
In der Version 17.0 hatte das Oberflächenmenü einen Button “Display Surface”, der vor
gab, wie die Oberflächengestaltung des Teiles erzeugt werden sollte, wenn sie die
Oberflächenfunktion benutzen.
Diese Möglichkeit ist durch eine andere: Face -Funktion ersetzt worden. Beachten Sie,
dass die Farbe der Ansicht in Attribute integriert ist, wo jedes seine eigene Registerkarte
hat.
Beispiel:
Im obengenannten Teil setzen Sie, wenn Sie zur Oberfläche kommen den
Werkzeugdurchmesser D auf 0 . Setzen Sie die Option Verbinden auf „Keine
Verbindung“. Und klicken Sie OK, um die Oberfläche zu erzeugen.
Danach wählt man im Menü Oberfläche die Funktion: Other, Face um das gerenderte
Teil zu erzeugen.
Mit der Funktion: View Options
können Sie das gerenderte Bild
regenerieren, um ein Bild von einer
Ansicht korrekt darzustellen.
Anmerkung: Dieser besondere Teil
könnte auch erzeugt worden sein,
ohne die Skin-Funktion zu
verwenden, da es ein einfaches Teil
ist. Tun Sie dieses mitder Funktion
Kette, die die zwei Endkurven
(Abschnitte) wählt, und verwenden
Sie dann die Funktion: Other:
Face.
33
Projektion auf eine Oberfläche
In diesem Beispiel wird ein Text auf eine Oberfläche projiziert.
Zeichnen Sie die 2 oben dargestellten Kurven
wie folgt:
Starten Sie eine neue Zeichnung und schalten
Sie 3-D ein. Danach klickt rechts mit der
Maus auf das UCS
(Benutzerkoordinatensystem). So dass das
Menü wie gezeigt geöffnet wird.
Wählen Sie Option Rotate aus dem Menü und
setzen die X-Rotation auf 90 Grad.
Danach: Funktion Arc: Coordinate Center und tragen Sie die folgenden Werte ein:
XC= 1.5, YC = -2, Radius = 2, Start Angle = 45, End Angle = 135.
Draw a second Arc with XC = 5.5, YC = -2, Radius = 2, Start Angle = 45, End Angle =
135.
Zeichnen Sie ein
Mittelstück zwischen
den 2 Bögen mit
Radius= 2 .
Folgendes ist zu
beachten: Wegen der
Rotation des UCS’s
sehen Sie Bogen 1
und Bogen 2 von der
Rückseite. Um das
Mittelteil richtig zu
34
zeichnen, Klicken Sie zuerst Bogen 2 und dann Bogen 1 an.
Nachdem Sie das Mittelteil zwischen Bogen 2 und Bogen 1 gezeichnet haben, wählen Sie
die ganze Kurve.
Danach klicken Sie das UCS
mit der rechten Maustaste
und wählen Sie Option
Reset. Dies stellt das UCS
auf die Originalposition und
die Originalausrichtung
zurück.
Verwenden Sie jetzt
Funktion Change:
Translate, um wie folgt eine
Kopie zu erzeugen: in der
Funktion Translate die Optionen wie hier zu sehen mit einer Verschiebung mit Z auf –4
setzen.
Kehren Sie danach zur oberen
Ansicht zurück.
Danach wählen Sie das Menü
Text und geben das Wort
Project ein. Setzen der
Texthöhe auf 0,7 und
markieren der Option Drag
text Stellen Sie
Schrifttypenstil auf „Wide
Latin” oder ähnlich.
Nun klicken Sie OK. Plazieren
Sie den Text zwischen die
zwei Kurven. Vergewissern
Sie sich, dass er nicht über die
Enden der Kurven hinausgeht, da sonst die Projektionsfunktion nicht ausgeführt wird.
35
Bevor wir den Text vektorisieren
(oder zerschlagen), führen wir,
um die Ansicht zu vergrößern
View All aus.
Danach im Menü Dimensions
Funktion Vectorize Text
auswählen und genau auf
0,0000005 setzen, wenn die
Genauigkeit zu groß gesetzt
wird, bringt der
Vektorisierungsprozess schlechte
Ergebnisse.
Dies ändert den Text in Linien und Bögen, die geplant und maschinell hergestellt werden
können.
Danach das Verketten der zwei Kurven in derselben Richtung ausführen. Als nächste
Menü 3-D: Set Surface: Interpolate nutzen. Dies definiert die 3-D Oberfläche auf die
projiziert werden soll.
Danach Menü Dimensions Vectorized Text wählen. Wählen Sie nun die Funktion 3-D
Projection. Der Text wurde auf die Oberfläche projiziert.
Im Beispiel unten verwendeten wir, um die Oberfläche zu definieren, die gleiche wellige
Kurve wie beim letzten Beispiel und eine gerade Linie. Bevor Sie das 3-D-Menü aufrufen
können, setzen Sie Set Surface: auf die Interpolate-Funktion. Sie müssen Funktion 3-D:
Equalize verwenden, um die Anzahl von Elementen in den beiden Kurven auszugleichen.
Die Kurven, die projektiert worden sind, waren ursprünglich eine spiralförmige Tasche in
einem Rechteck.
36
37
NC CAM
Die Version 18.0 kann die Datei mit dem NC-Code an eine Zeichnungsdatei angefügt
sein. Wenn eine Zeichnung gesichert wird, wird die NC-Datei damit auch gesichert.
Später, wenn Sie sich an eine Zeichnung wieder aufrufen wollen, wird die NC-Datei
gleichfalls wiederhergestellt.
Um das NC-CAM-Fenster zu öffnen, wählen Sie das Menü Special Funktion Insert NC.
Sie können auch auf dieses Icon klicken.
Ein spezielles Objekt ist in der Zeichnung geschaffen worden, es wird als Fräsmaschine
dargestellt. Dieses Objekt kann gelöscht oder mit dem Menü Change: Funktion Blank
unsichtbar gemacht werden. Wenn eine Zeichnung gerettet wird, ist das Objekt damit
gerettet und enthält die NC-Datei.
Mehrere NC-Dateien können zur selben Zeit geöffnet werden.
Sie können auch ein NC-CAM-Fenster durch Wählen des Menü File: New im CAD Teil
öffnen. Wählen Sie Select type NC File.
Viele der, von Version 18.0 gezeigten Funktionen sind die Gleichen, die Nutzer von
vorherigen BobCAD-Versionen kennen. Jedoch gibt es einige Änderungen und viele
neue Merkmale, die hier gestreift werden müssen.
Das Öffnen von NC-CAM:
Um NC-CAM zu öffnen, klicken Sie im Menü auf Funktion Insert NC. Ein Fenster
erscheint mit einer Liste von Pfostenprozessorkonfigurationen. Um einen von ihnen zu
verwenden, klicken Sie auf seinen Namen und OK. NC-CAM öffnet ein zweites Fenster
rechts vom CAD-Hauptfenster.
Schaffung einer neuen Postprozessorkonfiguration:
Wenn Sie die Funktion Insert NC aus dem Menü Special gewählt haben, können Sie eine
neue NC Nockenkonfiguration aus einer vorhandenen erzeugen. Im NC-Menü Setup
Funktion Configuration erscheint ein Fenster, hier schreiben Sie den Namen, den Sie
dem neuen NC-Maschinen Setup als Dateinamen geben wollen. Im gekennzeichneten
Fenster „New Setup based on“, klicken sie den kleinen Pfeil neben der Textbox und
wählen den Namen der Konfiguration, mit der Sie gerne beginnen würden. Auf diese
Weise kann vieles, was in einer Konfiguration bereits vorhanden ist genutzt werden, so
dass Sie es nicht machen müssen. Wenn Sie „OK“ klicken, öffnet sich NC-CAM mit
dieser Konfiguration, auf die Sie Ihre neue beziehen und Sie können die Einstellungen
verändern.
38
NC-CAM Menüs:
NC-CAM Menüs haben sich etwas verändert. Vor allem zu bemerken, Sie haben Cycle,
Tool, Contour, und Macro (Zyklus, Werkzeug, Kontur und Makro).
Das Makro -Menü
Das Makromenü in der Art dem Menü der vorherigen Version.
Es kann auf die gleiche Art bedient und geändert werden, wie seine Vorgänger.
Das Werkzeug-Menü
Das Werkzeugmenü ist auch das gleiche wie bei den vorherigen Versionen.
Werkzeugzeichnungen gehören jetzt zu NC-CAM: Edit: Tool und nicht mehr in
NC-CAM Setup: Tool-Button. Werkzeugzeichnungen lassen sich aus einem
Konturunterverzeichnis auswählen.
Das Zyklus-Menü
Das Zyklusmenü ist, eine Möglichkeit mit der wir eine NC-CAM Unterstützung
für die vorhandenen Maschinenzyklen geben. Verwenden Sie dieses Menü, um
Zyklen Ihrer Maschine einzugeben, wie bohren, reiben, einfädeln usw.. Um dies
zu tun, klicken Sie auf das Menü Setup und wählen Cycle.
Ihnen wird ein Fenster geöffnet, um die Funktionen in dem Zyklusmenü zu
verändern. Diese werden auf die gleiche Weise hinzugefügt und gelöscht, wie in
vorangangenen Versionen von BobCAD. Wenn Sie auf Modify (ebenso wie bei
“Edit” von älteren Versionen) klicken, können Sie eine Box mit vier
Unterteilungen sehen, in die Sie die Daten, wie unteren stehend eingeben
können.
39
Hier ist ein Feld für die erste Zeile des Zyklus, eines für die letzte Zeile des
Zyklus und eines für die Zeilen dazwischen. In der Box mit der Bezeichung “NC
lines for one point”, würden sie normalerweise die Zeilen für den ersten und
letzten Punkt einfügen. Um die Koordinaten der beim Zyklus verwendeten
Punkte anzugeben, schreiben Sie das noch nicht vorhandene Makro- '@C', das
NC-CAM auffordert die Koordinaten der Punkte (oder des Endpunkts einer Linie
oder eines Bogens) anzugeben. Im obengenannten Beispiel würde dies einen
Satz von Bohrerzyklen generieren. Wählen Sie zuerst die Punkte, bevor Sie die
Bohrfunktion anklicken. Beachten Sie, dass die Version 17.0, um die Eingabe
Werte der Bohrparameter bat. In Version 18.0 müssen Sie diese auch in einem
NC-CAM-Fenster eingeben, oder Sie können viele Ihrer bevorzugten
Bohrerzyklen erzeugen oder sich eine maßgeschneiderte Skriptdatei für Ihre
Maschine schaffen. In den nächsten Monaten stellt BOBCAD-CAM einen Satz
von Skriptdateien für das Bohren zur Verfügung. Bitte sehen Sie unsere WebSite regelmäßig nach diesen Aktualisierungen durch. Unten ist noch ein anderes
Beispiel für Bohrerzyklen.
Sie können auch das Zyklusmenü für die noch nicht vorhandenen
Konfigurationen und weiter Beispiele nutzen.
Nachdem Sie diese Sachen geändert haben, klicken Sie OK und gehen ganz
zurück zum Hauptfenster von NC-CAM. Von hier klicken Sie auf Maschine und
dann Drill, um sie zu verwenden. Jeder Zyklus erscheint hier im Menü, so dass
Sie ihn wählen können.
40
Das Kontur-Menü
Das Konturmenü wird vielfach auf dieselbe Weise, wie das Zyklusmenü erzeugt,
außer dasdas, was auch immer als aktive Einstellung im Konturmenü aktuell
vorhanden ist, für alle NC Codes wirksam ist. Auf diese Weise kann NC-CAM
Dinge machen, wie automatische Schneidenkompensation für Fräsvorgänge ohne
das Sie es aus einem Menü wählen müssen, um das ein- und auszuschalten. Beim
Konturmenü sehen Sie die Konfigurationen für besondere Beispiele wieder.
Zusätzlich zu den oben erwähnten Sachen hat das Zyklusmenü auch die
Fähigkeit zum Aufrufen eines vorgeschriebenen Skripts, anstatt des Änderns des
Zyklus auf die normale Weise. Sehen Sie als ein Beispiel das G81 Skript im
Skriptverzeichnis. In der „ISO Sample“-Konfigurationsdatei wird dieses Skript
(mit dem Namens- „Zyklus“) vom G81 Zyklus aufgerufen. Laden Sie diese
Konfigurationsdatei und verwenden Sie den G81 Bohrungszyklus, um es real zu
sehen. BobCAD’s Skripterzeugung kann, wenn es in seiner Anwendung mit den
Menüs verbunden wird ein unglaublich leistungsfähiges Werkzeug sein. Sie
konnten zum Beispiel eine Skript schreiben, das nur nach einzelnen Parametern
fragt, die mit dem Einfädeln zu tun haben. Dieses G81 Skript ist nur eine sehr
kleine Probe von dem, was alles möglich ist. Für die Information, wie man die
Skripts programmieren kann, gibt BobCAD, sobald es fertig ist, ein vollständiges
Programmierhandbuch heraus.
Die Werkzeugleisten in NC-CAM werden auf dieselbe Weise,wie die
Werkzeugleisten in der CAD-Seite kontrolliert, redigiert und modifiziert. Bitte
lesen Sie jene Abschnitte dieses Nachtrags für weitere Details.
41
BobCAD-CAM Version 18.0 CAM-Lektion: Bohr-zyklen
Manche der Änderungen am CAM-Teil von BobCAD sind in dem Kontur- und dem
Zyklus-Menü enthalten. Im Besonderen sind die Möglichkeiten die von BobCAD
unterstützten Zyklen zu ändern und neu zu konfigurieren besser geworden. Diese Lektion
liefert Ihnen eine Einführung.
Zu Beginn, klicken Sie auf '“Special“ im Hauptmenü und wählen „Insert NC”. Im
Fenster, welches erscheint, wählen Sie „Fanuc Mill“ auf der linken Seite und klicken OK.
Ein neues NC-CAM-Fenster erscheint.
Im NC-CAM-Fenster wählen Sie „Setup“ und dann „Cycle“. Ein Fenster öffnet sich. Es
ähnelt den „Change Custom Menu“ und „Change Tool Menu“ Fenstern in vorherigen
Windows Versionen von BobCAD. In diesem Fenster wählen Sie „G81 &Spot Drill“.
klicken Modify. Ein neues Fenster mit vier Teilen erscheint, diese sind nie in vorherigen
Versionen erschienen. In einem ist aufgeführt „NC Lines first point“, in dem anderen
Fenster „NC Lines intermediate points“ und in den anderen zwei „NC Lines last point“
und „NC Lines one point“. Wie erwartet werden kann, stellt jede dieser Boxen
verschiedene Punkte dar, die während der Abarbeitung des Zyklus gewählt werden
können.
Da diese Konfiguration den Großteil der für die Fanuc-Konfiguration verfügbaren
Bohrungszyklen schon hat, fügen wir eine Art “Nonsens”-Zyklus hinzu, um eine gute
Anregung zu geben, wie es funktioniert.
Wenn Sie noch die 4-geteilte Box für den G81 Zyklus haben, klicken Sie „Cancel“. Wir
werden zurück zum Menü „Change Cycle Menu“ gebracht. In diesem Fenster klicken
Sie auf eine Leerzeile unterhalb des auf der linken Seite aufgeführten letzten Zyklus. Die
Leerzeile wird in blau hervorgehoben. Dann schreiben Sie in der Textbox nahe dem oben
befindlichen „Menu Text“ „Bob Cycle”. Dies wird der im Zyklusmenü und unter
„Machine->Drill“ aufgeführte Name sein.
Klicken Sie auf den „Modify“-Button. Ein 4-geteilte Box erscheint, die der, die wir schon
gesehen haben ähnelt. Unter “NC Lines first point“ geben Sie „Bob @C“' und
<ENTER> ein. Der Teil „Bob“ von diesem wird der Name sein, der am Anfang der
ersten Zeile des Zyklus erscheint. Das „@C“ ist ein Makro, welches BobCAD sagt, dass
hier die Stelle ist, wo die Koordinaten dieses ersten Punktes in die Zeile eingefügt
werden. Das <ENTER> bringt lediglich den Cursor zur nächsten Zeile hinunter. Wenn
wir das <ENTER> nicht verwendeten, würde der nächste Teil des Zyklus auf derselben
Zeile wie der vorhergehende erscheinen.
In dem mit „NC Lines intermediate points“ gekennzeichneten Box geben Sie „@C“' und
<ENTER> ein. Wenn im Zyklus „Bob“ nicht auf jeder Zeile sein muß, müssen wir es
einfach nicht eingeben. Genau so, wenn Ihr Zyklus die Koordinaten in jeder Zeile braucht
42
und die <ENTER> -Taste, dann tun Sie exakt dasselbe, wie in der ersten Zeile des
Zyklus.
Unter „NC Lines last point“, geben wir die Koordinaten des letzten Punktes an, den wir
für den Zyklus ausgewählt haben und so beenden wir den Zyklus. Also geben Sie in diese
Box „@C“ auf der ersten Zeile in der Box und das Wort „Cycle“ in der darunterliegenden
Zeile ein. Wie zuvor stellt „@C“ die Koordinaten des Punktes dar. „Cycle“ bezeichnet
hier jedoch das Ende des Zyklus. In einer normalen Maschine sind Bohr- (und andere)
Zyklen, als „G80“ definiert. Sehen Sie die anderen Zyklen in diesem Menü als Beispiele.
In der letzten Box müssen wir wissen, was zu tun ist, wenn wir nur einen Punkt haben,
den wir in unseren Zyklen verwenden können. In diesem Fall brauchen wir den
Zyklusanfang, die Koordinaten und das Ende in ein- und derselben Box. In dieser Box
geben Sie „Bob @“, <ENTER> und „Cycle“ ein, gefolgt von erneut der <ENTER> Taste und klicken „OK“.
Nun, da wir unsere Zyklen aufgelistet haben, klicken wir wieder „OK“. Jetzt sollten wir
zum Hauptfenster des NC-CAM zurückkehren.
Wenn sich eine Zeichnung nicht starten ließ, starten Sie erneut durch klicken auf „File“
im Hauptmenü auf der CAD Seite.
Um auf Ihre Punkte für die Anwendung des Zyklus „Nonsens“ zu gelangen, wählen Sie
aus dem Hauptmenü „Point“ und klicken „Sketch”. Klicken Sie jetzt einige Male im
Zeichnungsfenster. Es sollten einige Punkte, wo immer Sie klicken, gezeichnet werden.
Wählen Sie diese Punkte durch Anklicken von „Edit“ aus dem Hauptmenü und „All“. Es
gibt viele Arten, die Punkte die wir gerade gezeichnet haben zu markieren, wenn Sie mit
einer anderen Methode komfortabler zurecht kommen, verwenden sie diese. Wir stören
uns nicht daran.
Wechseln Sie auf die NC-CAM Seite und klicken Sie auf „Maschine“ anschließend auf
„Drill“. Unsere Zyklus „Nonsens“ sollten dort aufgelistet sein. Klicken Sie darauf und
dann auf „OK“.
Unser Unsinnzyklus hat gerade keinen „Nonsens“-Code generiert
Die Alternativmethode dafür, unseren Zyklus zu verwenden ist, zuerst zum Menü
„Maschine“ zu gehen und „Dill“ wählen. Wenn wir auf unseren Zyklus klicken und
„OK“und wir noch nichts auf der CAD-Seite gewählen haben, wird BobCAD’s
integrierter Zyklusgenerator eine Box öffnen und uns fragen, welche Art der
Auswahlmethode wir möchten. Wir würden die Methode wählen, „OK“ klicken und auf
alle unsere Punkte klicken, die wir haben wollen. Wenn wir das getan haben, klicken Sie
nur den rechten Mausknopf, um BobCAD zu sagen, dass wir mit unserer Auswahl fertig
sind, und BobCAD wird unseren Code in einem Augenblick generieren
43
Nun, wir wollen nicht überall den Nonsens-Zyklus anwenden. Folglich, da BobCAD
unseren Änderungen an unserer Postprozessorkonfigurationen automatisch
standardmäßig („Fanuc Mill“, den wir am Anfang der Lektion wählten) sichert, müssen
wir den Zyklus entfernen, um zu vermeiden, das er zufällig gewählt wird, wenn die Zeit
kommt richtige Zyklen zu wählen.
Klicken Sie auf „Setup“ in NC-CAM, gefolgt von „Cycle”. Wir sehen das „Change cycle
menu“ erneut. Dieses Mal klicken Sie auf unseren „Bob Cycle“ Zyklus und dann
„Delete“. Klicken Sie „OK“ und wir werden dorthin zurück gekommen sein, wo wir
begonnen haben.
44
Neuen Nullpunkt einstellen
Frühere Versionen von BOBCAD hatten, in NC-CAM eine Funktion „New Zero“
genannt. Dies gestattet es dem Benutzer den Ursprung zu ändern, aus dem der G-Code
generiert wird. In Version 18.0 müssen Sie das UCS (Benutzerkoordinatensystem)
verwenden. Wir beziehen uns auf einen früheren Abschnitt in diesen Ergänzungen. Dort
steht, wie man das UCS verwenden kann.
45
Visual Basic Skripte schreiben
BOBCAD 18.0 erlaubt dem Benutzer, Programme in Basic zu schreiben und diese mit
BOBCAD zu verbinden. Solch ein Programm kann Dialoge auf dem Bildschirm
plazieren, die Fragen stellen und den Benutzer zur Werteeingabe auffordern. Es kann
vorhandene Elemente auf dem Bildschirm untersuchen, die dann verarbeitet werden
können. Es kann auch Elemente auf dem Bildschirm zeichnen, solche Funktionen, wie
Kopie und Einfügen aufrufen und auch als NC-Code im NC-CAM- Fenster generieren.
Ein spezielles Handbuch wird geschrieben, um diese Merkmale zu beschreiben. Wenn
Sie Basic kennen, können Sie das auch ohne das Handbuch verstehen. Wir haben
spezielle Funktionen entwickelt, die das Basic an das BOBCAD ankoppeln. Um diese zu
erlernen, können Sie das Menü Special: Funktion Record Script verwenden:
Zum Beispiel. Wählen Sie Funktion Special: Record Script und starten New script.
Geben Sie einen Namen für dieses Skript und OK ein. Zeichnen Sie danach eine Linie
mit Koordinaten. Nachdem die Linie gezeichnet ist, wählen Sie Funktion Special: Record
Script und dann Stop. Die Skriptdatei wurde nun auf der Festplatte mit der Endung .bas
(für Basic) gespeichert.
Sie können diese Skriptdatei jetzt wie folgt betrachten: Wählen Sie Funktion Special:
Script. Wählen Sie die Basic-Datei, welches Sie erzeugt haben und Klicken Sie auf
Modify. Sie können nun die Skript-Datei folgendermaßen aufrufen: wählen Sie das Menü
Special: die Basic-Datei die Sie erzeugt haben und klicken darauf. Sie werden jetzt die
Zeile sehen mit der das BOBCAD Basic Skript sie auffordert die Koordinaten für das
Zeichnen der Linie einzugeben.
Bitte beachten Sie, dass die gewählte Einheit Millimetern ist. Alle Werte sind für Zoll mit
25,4 zu multiplizieren.
BOBCAD hat spezielle Funktionsanrufe geschaffen , um Programme, die in Zoll
geschrieben sind anzupassen.
Es gibt mehrere schon verfügbare Skriptdateien. Viel mehr werden noch entwickelt und
zur Verfügung gestellt. Wenn Sie Skriptdateien geschrieben haben, die auch für andere
von Interesse sein können, können Sie uns diese für die Veröffentlichung auf unserer
Web-Seite zusenden. Sie wollen vielleicht für einige von diesen die Kosten erstattet
bekommen.
Senden Sie die Skriptdateien an Bob12@pacbell.net.
46
INDEX
3-D Oberflächen ................................ 28
5-Achsen Ausgabe .............................. 28
Ändern ............................................... 20
Anordnen ........................................... 27
Anpassen ............................................ 31
Ansichtsoptionen ............................... 17
Attribute .............................................. 19
Aufräumen......................................... 18
Ausgleichen........................................ 31
Auswahlmodus .................................... 7
Bemaßung .......................................... 19
Benutzerkoordinatensysteme (UCS) 25
Bohren................................................ 42
Bohrzyklen.......................................... 40
Corel Draw.......................................... 18
Dynamische Drehen............................ 17
Dynamische Umschalten .................... 17
EIGENSCHAFTEN SETZEN ......... 12
großer Monitor.................................... 2
Icons und Werkzeugkästen .............. 15
Kontur ................................................ 41
lange Dateinamen.................................. 2
Makro................................................. 39
mehrere Zeichnungen............................ 5
NC CAM ............................................ 38
Neuen Nullpunkt ............................... 45
Oberfläche ......................................... 28
Postprozessor..................................... 38
Projektion .......................................... 34
Raster .................................................. 13
Registerkarten ..................................... 12
Rendering........................................... 33
Reorganisieren .................................... 18
Skripte schreiben .............................. 46
Smash
explode............................................. 24
Smash text.......................................... 24
Starten einer neuen Zeichnung oder
mehrerer Zeichnungen.................... 5
Text..................................................... 19
Text entlang eines Pfades ................. 23
Toleranzen........................................... 19
Umwandeln........................................ 27
Vektorisieren....................................... 24
Verschiedene Ansichten.................... 11
Visual Basic........................................ 46
Werkzeug ........................................... 39
Zerschlagen ......................................... 24
Zyklus................................................. 39
47
Document
Kategorie
Technik
Seitenansichten
2
Dateigröße
1 527 KB
Tags
1/--Seiten
melden