close

Anmelden

Neues Passwort anfordern?

Anmeldung mit OpenID

Bedienungsanleitung KnowHowDB - Incite GmbH

EinbettenHerunterladen
Bedienungsanleitung KnowHowDB
Herausgeber:
Incite GmbH
Version:
4.4.a
Letzte Änderung:
06.01.2010
Alle Rechte vorbehalten. Kein Teil des Werkes darf in irgendeiner Form (Druck, Fotokopie, Mikrofilm oder einem anderen Verfahren) ohne
schriftliche Genehmigung von der Firma Incite GmbH reproduziert oder unter Verw endung elektronischer Systeme verarbeitet, vervielfältigt
oder verbreitet w erden.
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 1 of 82
Programm Oberfläche
Page 2 of 82
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 3 of 82
Eintrag
Neuer Eintrag
Wählen Sie eine Kategorie oder den Arbeitsplatz aus und klicken Sie auf Neuer Eintrag.
l
l
l
l
l
Beliebige Informationen werden in einem Eintrag gespeichert.
Der Eintrag besteht aus einem Titel-, Notiz- und Textfeld, Linkstabelle und der Historie.
Alle Einträge werden zentral in einer Datenbank abgelegt.
Der Eintrag ist mit einem Microsoft Word Dokument zu vergleichen.
Einträge können per Drag & Drop verschoben werden.
Neue Kategorie
Wählen Sie eine Kategorie oder den Arbeitsplatz aus und klicken Sie auf Neue Kategorie.
l
l
l
In Kategorien werden Einträge abgelegt und strukturiert.
Die Kategorien sind mit Ordner im Windows Explorer zu vergleichen.
Kategorien inkl. Einträge können per Drag & Drop verschoben werden.
Neue Vorlage
1. Wählen Sie eine Kategorie oder den Arbeitsplatz aus und klicken Sie auf Neue Vorlage.
2. Mit der rechten Maustaste in der Baumstruktur eine Vorlage wählen und
3. im Kontextmenü auf Neuer Eintrag aus dieser Vorlage klicken.
l
l
l
Mit Vorlagen können Briefe, Protokolle oder Berichte einmal mit all ihren Formaten, Layout und Grafiken
gespeichert und daraus neue Einträge erstellt werden.
Die Vorlage kann in Kategorien abgelegt werden wie Einträge.
Vorlagen sind mit einem roten Pin markiert.
Beispiele
Speichern
Der aktuelle Eintrag wird gespeichert.
Löschen
Der aktuelle Eintrag wird gelöscht und in den Papierkorb verschoben.
l
Mit der rechten Maustaste im Papierkorb den gewünschten Eintrag anklicken und Wiederherstellen wählen. Der
Eintrag wird in derselben Kategorie wieder erstellt. Besteht diese nicht mehr, so erscheint er unter dem
Arbeitsplatz.
Umbenennen
Der aktuelle Eintrag wird umbenannt.
Schliessen
Der aktuelle Eintrag wird geschlossen.
Seite einrichten...
Die Papiergrösse, Hoch- oder Querformat und die Seitenränder können hier definiert werden.
Seitenansicht...
Der aktuelle Eintrag wird in einer Seitenvorschau angezeigt.
Drucken...
Der aktuelle Eintrag wird gedruckt.
Senden an...
Der aktuelle Eintrag kann per E-Mail versendet oder in eine Datei gespeichert werden.
E-Mail-Empfänger
Der Inhalt von einem Eintrag wird in den E-Mail Body geschrieben.
Page 4 of 82
E-Mail-Empfänger (als Anlage im Outlook)
Der Inhalt von einem Eintrag wird als Anlage in einem E-Mail angehängt.
Datei
Eine Datei wird im gewünschten Format gespeichert.
Importieren
Siehe Importieren...
Exportieren
Siehe Exportieren... Beenden
KnowHowDB wird geschlossen.
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 5 of 82
Menü Bearbeiten
Rückgängig
Die Eingabe im Textfeld wird rückgängig gemacht.
Wiederholen
Die Funktion Rückgängig wird wiederhergestellt.
Ausschneiden
Der markierte Text wird ausgeschnitten und im Zwischenspeicher abgelegt.
Kopieren
Der markierte Text wird kopiert und im Zwischenspeicher abgelegt.
Einfügen
Der im Zwischenspeicher befindliche Text wird beim Cursor eingefügt. Die Formatierung bleibt vorhanden.
Einfügen als Text
Der im Zwischenspeicher befindliche Text wird beim Cursor eingefügt. Die Formatierung wird dabei nicht
übernommen vorhanden.
Format übertragen
Markieren Sie den gewünschten Text, klicken auf Format übertragen und wählen den zu ändernden Text. Das
Format wird auf den neuen Text übernommen.
Löschen
Link löschen
Der gewählte Link in der Linkliste wird gelöscht. Kopf- und Fusszeile
Löscht die Kopf- und Fusszeile auf der ersten Seite, sowie auf allen Folgeseiten.
Kopf- und Fusszeile Standard
Löscht die Kopf- und Fusszeile auf allen Folgeseiten, ohne erste Seite. Kopf- und Fusszeile erste Seite
Löscht die Kopf- und Fusszeile auf der ersten Seite.
Alles markieren
Markiert kompletten Text im Textfeld.
Suchen...
Sucht einen bestimmten Text innerhalb vom Textfeld.
Ersetzen...
Ersetzt einen bestimmten Text mit einem anderen im Textfeld.
Gehe zu
Kopfzeile Standard
Springt mit dem Cursor zur Kopfzeile der zweiten Seite.
Kopfzeile erste Seite
Springt mit dem Cursor zur Kopfzeile der ersten Seite.
Fusszeile Standard
Springt mit dem Cursor zur Fusszeile der zweiten Seite.
Fusszeile erste Seite
Page 6 of 82
Springt mit dem Cursor zur Fusszeile der zweiten Seite.
Rückwärts
Blättert jeweils einen Eintrag der bisher geöffneten Einträge zurück.
Vorwärts
Blättert jeweils einen Eintrag der bisher geöffneten Einträge vorwärts.
Hyperlink ändern...
1. Markieren Sie den gewünschten Hyperlink rechts vom Text
2. Wählen Sie Hyperlink ändern...
3. Ändern Sie den Text
Textmarke...
Textmarken dienen dazu, dass mit einem Hyperlink zu einer bestimmten Textmarke innerhalb vom Textfeld
gesprungen werden kann. Eine Anwendung wäre z. B. ein Inhaltsverzeichnis.
l
l
Mit Gehe zu springen Sie zu einer beliebigen Textmarke.
Mit Löschen löschen Sie eine beliebige Textmarke.
Link ändern...
Der markierte Link in der Links Liste kann bearbeitet werden.
Metadaten Vorlage zuweisen
Über diese Menü werden die Metadaten Vorlagen einer Kategorie und Benutzer / Gruppe zugewiesen, siehe
Metadaten Beschreibung.
Berechtigungen...
Arbeitsplatz, Kategorien, Einträge und Vorlagen können für eine Benutzergruppe und/oder einen Benutzer mit
folgenden Kriterien berechtigt werden:
l
l
l
l
l
l
Vollzugriff
Neu
Bearbeiten
Löschen
Lesen
Berechtigungen
Übersicht aller Berechtigungen im Detail.
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 7 of 82
Menü Ansicht
Ansicht Normal
1. Arbeiten Sie zum Eingeben, Bearbeiten und Formatieren von Text in der Normalansicht. Eine Ansicht, in der die
Textformatierung und ein vereinfachtes Seitenlayout angezeigt werden.
2. Die Normalansicht eignet sich für die meisten Bearbeitungs- und Formatierungsvorgänge. In der Normalansicht
werden Textformatierungen angezeigt. Das Layout eines Eintrages wird jedoch vereinfacht dargestellt, um eine
schnelle Texteingabe und -bearbeitung zu ermöglichen.
Ansicht Seitenlayout
l
l
Die Ansicht Seitenlayout zeigt die Einträge so an, wie sie gedruckt aussehen. So werden beispielsweise
Elemente wie Kopf- und Fusszeilen und Seitenumbrüche in ihren tatsächlichen Positionen angezeigt.
Diese Ansicht ist nützlich, wenn Sie Kopf- und Fusszeilen bearbeiten oder Seitenränder anpassen.
Ansicht Text
Die Textansicht ist ähnlich wie die Normalansicht. Die Zeilen werden nicht beim rechten Rand des Eintrages
umgebrochen, sondern orientiert sich an der Breite des Textfeldes.
Kopf- und Fusszeile wechseln
Bewegt den Cursor von der Kopfzeile in die Fusszeile und umgekehrt.
Formatierungszeichen
Die Formatierungszeichen werden eingeblendet.
Layout wiederherstellen
Die Panelanordnung wird wieder auf ihren Originalzustand zurückgesetzt.
Panels sperren
Panels können nicht mehr verschoben. Wenn Sie die Panels nach Ihrem Gusti eingerichtet haben, können Sie
diese Sperren, damit Sie nicht aus versehen die Einstellungen ändern.
Statusbar anzeigen
Die Statusbar zeigt Ihnen wichtige Informationen am unteren Bildschirmrand an. Angezeigt werden das Datum, die
Anzahl der Suchresultate, den Benutzernamen, die Benutzergruppe und ob der angemeldete Benutzer ein
Systemadministrator ist.
Symbolleiste
Vordefinierte und eigens erstellte Symbolleisten können ein- und ausgeblendet werden.
Panel
Das Suchen, die Baumstruktur, die Suchliste, die Favoriten, die Links, die Bildvorschau und die Historie
befinden sich in so genannten Panels, auch Fenster genannt. Diese können nach belieben verschoben, vergrössert
und verkleinert oder an andere Panels angedockt werden.
Aktualisieren
Mit Aktualisieren aktualisieren Sie die Baumstruktur neu, d. H. wenn ein anderer Benutzer ein neuer Eintrag anlegt,
so erscheint dieser erst, nachdem die Baumstruktur aktualisiert wurde.
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 8 of 82
Menü Einfügen
Grafik...
1.
2.
3.
4.
5.
l
l
l
Klicken Sie auf die Stelle, an der die Grafik eingefügt werden soll.
Klicken Sie im Menü Einfügen auf Grafik einfügen...
Suchen Sie die einzufügende Grafik.
Doppelklicken Sie auf die Grafik, die Sie einfügen möchten.
Folgende Grafiktypen können eingefügt werden:
l JPEG File Interchange Format (*.jpg;*.jpeg)
l Portable Networks Graphics (*.png)
l GIF Graphics Interchange Format (*.gif)
l Windows-Bitmap (*.bmp)
l Tag-Grafik-Dateiformat (*.tif;*.tiff)
l Windows Metafile (*.wmf)
Die Grafiken werden standardmässig im definierten Pfad (einstellbar in den Optionen) abgelegt und im Eintrag
verknüpft.
Die Grafikeinstellungen können unter dem Menü Format-Grafikeigenschaften... definiert werden.
Die Grafik kann beliebig vergrössert und platziert werden.
Metadaten-Attribut einfügen
Gewünschte Metadaten Attribute können ins Textfeld zur Anzeige und zum Drucken eingefügt werden.
Textfeld
1. Menü Textfeld einfügen wählen
2. Ziehen Sie den Mauszeiger, oder klicken Sie in Ihrem Dokument auf die Stelle, an der das Textfeld eingefügt
werden soll.
l
Ein Container für Text oder Grafiken, der verschoben und in der Grösse geändert werden kann. Verwenden Sie
Textfelder, wenn Sie mehrere Textblöcke in einem Eintrag anordnen oder einen bestimmten Textabschnitt anders
ausrichten möchten als den restlichen Text in einem Eintrag.
Textmarke...
1. Wählen Sie ein Element aus, dem Sie eine Textmarke zuweisen möchten, oder klicken Sie auf die Stelle, an
der Sie eine Textmarke einfügen möchten.
2. Klicken Sie im Menü Einfügen auf Textmarke.
3. Geben Sie einen Namen ein.
4. Klicken Sie auf OK.
l
Textmarken dienen dazu, dass mit einem Hyperlink zu einer bestimmten Textmarke innerhalb vom Textfeld
gesprungen werden kann. Eine Anwendung wäre z. B. ein Inhaltsverzeichnis.
Kopf- und Fusszeile
Standard
Kopf- und Fusszeile einfügen ab der zweiten Seite bis zum Dokumentende. Erste Seite
Kopf- und Fusszeile einfügen auf der ersten Seite. Seitenzahl einfügen
Fügt auf jeder Seite die aktuelle Seitenzahl ein. Anzahl der Seiten einfügen
Fügt auf jeder Seite die gesamte Anzahl Seiten des Eintrages an.
Hyperlink...
1.
2.
3.
4.
Wählen Sie den gewünschten Text aus.
Wählen Sie Menü "Einfügen-Hyperlink...".
Name eingeben.
Auswahl ob zu einem Hyperlink gesprungen werden soll, eine Datei geöffnet oder ein E-Mail versendet.
Seitenumbruch
1. Klicken Sie auf die Stelle, an der die neue Seite beginnen soll.
2. Klicken Sie im Menü auf "Einfügen-Seitenumbruch".
Page 9 of 82
2. Klicken Sie im Menü auf "Einfügen-Seitenumbruch".
Datei...
1.
2.
3.
4.
5.
Klicken Sie im Menü Einfügen auf Datei...
Wählen Sie mit dem Symbol ... eine gewünschte Datei aus.
Der Name wird von der Datei übernommen. Sie können diesen nach belieben ändern.
Wählen Sie, ob die Datei verlinkt werden soll, oder in den in den Optionen definierten Pfad kopieren soll.
Optional lässt sich auch eine Beschreibung und eine eindeutige fortlaufende Nummer einfügen.
Webseite...
1. Klicken Sie im Menü Einfügen auf Webseite...
2. Geben Sie den Namen und die Adresse der Webseite ein.
3. Optional lässt sich auch eine Beschreibung und eine eindeutige fortlaufende Nummer einfügen.
E-Mail...
1. Klicken Sie im Menü Einfügen auf E-Mail...
2. Geben Sie den Namen und die E-Mail Adresse ein.
3. Optional lässt sich auch eine Beschreibung und eine eindeutige fortlaufende Nummer einfügen.
Medien...
1.
2.
3.
4.
Klicken Sie im Menü Einfügen auf Medien...
Geben Sie den Medientyp z. B. CD, DVD oder Buch ein.
Geben Sie den Standort ein.
Optional lässt sich auch eine Beschreibung und eine eindeutige fortlaufende Nummer einfügen.
Datum...
Öffnet einen Kalender womit man ein gewünschtes Datum einfügen kann.
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 10 of 82
Format
Zeichen...
Wählen Sie hier die gewünschte Schriftart, Schriftgrösse, Schriftmerkmale, Position, Farbe und Texthintergrund.
Styles...
1.
2.
3.
4.
5.
6.
7.
8.
9.
Klicken Sie auf Format Styles...
Klicken Sie auf Neu um ein neues Format zu erstellen.
Geben Sie einen Namen ein.
Wählen Sie unter Basiert auf eine Formatvorlage, welche als Basis verwendet wird. Die Einstellungen werden
von dieser Vorlage übernommen.
Wählen Sie die Formatvorlage, welche für den nächsten Absatz automatisch übernommen wird.
Wählen Sie zwischen dem Formatvorlagentyp Absatz oder Zeichen. Absatz gilt für einen kompletten Absatz
und Zeichen gilt nur für eine Zeichenkette in mitten eines Satzes.
Wählen Sie die Formatierungen wie Schriftart, Absatz, Tabulatoren und Nummerierung.
Klicken Sie auf OK
Die definierten Formatvorlagen können nun in der Symbolleiste gewählt werden.
Absatz und Rahmen...
Wählen Sie die gewünschten Absatzformatierungen oder einen Rahmen.
Numerierung und Aufzählung...
Wählen Sie die Einstellungen für die Nummerierung und Aufzählung.
Fett
Markierter Text wird Fett dargestellt.
Kursiv
Markierter Text wird Kursiv dargestellt.
Unterstrichen
Markierter Text wird Unterstrichen dargestellt.
Linksbündig
Markierter Text wird linksbündig gesetzt. Zentriert
Markierter Text wird zentriert gesetzt. Rechtsbündig
Markierter Text wird rechtsbündig gesetzt. Blocksatz
Markierter Text wird als Blocksatz gesetzt. Vergrössern
Der gewünschte Text wird um einen Punkt vergrössert..
Verkleinern
Der gewünschte Text wird um einen Punkt verkleinert.
Grafikeigenschaften...
1. Markieren Sie die gewünschte Grafik.
2. Klicken Sie auf das Menü Grafikeigenschaften...
3. Wählen Sie die gewünschten Eigenschaften aus.
l
l
l
Daten in Dokument einbetten; die Grafik wird anstelle einer Datei in der Datenbank gespeichert.
Name der Originaldatei einbetten; die Grafik wird mit der eingefügte Originaldatei verknüpft.
Bild exportieren und Dateinamen einbetten; die Grafik wird als Datei exportiert (Pfad in den Optionen wählbar) und
mit ihr verknüpft.
Page 11 of 82
Textfeldeigenschaften...
1. Markieren Sie das gewünschte Textfeld.
2. Wählen Sie die gewünschten Textfeldeigenschaften aus.
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 12 of 82
Extras
Benutzer
Verwalten...
Siehe Benutzerverwaltung
Passwort ändern...
Jeder Benutzer kann hier sein eigenes Passwort ändern.
Umgebung
Umgebung bearbeiten
Siehe Umgebung bearbeiten
Backup erstellen
Mit dieser Funktion wird ein komplettes Backup aller relevanten Daten erzeugt.
Metadaten
Metadaten bearbeiten
Metadaten Attribute einfügen und bearbeiten, siehe Metadaten.
Vorlagen bearbeiten
Metadaten Vorlagen einfügen und bearbeiten, siehe Metadaten
Datenbank
Aktuelles Datenbankkennwort ändern
Ändert das aktuelle Datenbankkennwort. Diese Kennwort dient dazu, dass unbefugte die SQL oder Access
Datenbank öffnen können.
Aktuelle Datenbank komprimieren
Komprimiert die aktuelle Datenbank. Um eine optimale Leistung sicherzustellen, sollten Sie die Datenbank
regelmässig komprimieren.
Historie
Die Historie zeichnet alle Änderungen auf und stellt Sie in einem Panel dar. Natürlich werden all diese Änderungen
in der Datenbank abgelegt. Der Speicherbedarf über mehrere Jahre ist nicht unbedeutend. Deshalb können Sie mit
dieser Funktion die Historie Einträge bis zu einem bestimmten Datum löschen.
Sonstige
Direkter Zugriff auf folgende Windows Programme:
l
l
l
Rechner
Zeichentabelle
Editor
Optionen
Siehe Optionen
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 13 of 82
Tabelle
Einfügen-Tabelle...
1. Klicken Sie auf das Menü Einfügen-Tabelle...
2. Wählen Sie die Anzahl Spalten und Zeilen
3. Klicken Sie auf OK
Einfügen- Spalte nach rechts
Fügt eine Spalte auf der rechten Seite des Cursors ein.
Einfügen- Spalte nach links
Fügt eine Spalte auf der linken Seite des Cursors ein.
Einfügen- Zeile nach oben
Fügt eine Zeile oberhalb des Cursors ein.
Einfügen- Zeile nach unten
Fügt eine Zeile unterhalb des Cursors ein.
Löschen-Tabelle
Löscht die gesamte markierte Tabelle.
Löschen-Spalte
Löscht die markierte Spalte.
Löschen-Zeile
Löscht die markierte Zeile.
Tabelleneigenschaften...
Tabelleneigenschaften wie Rahmen, Schattierungen, Abstände usw. werden hier definiert.
Auto Anpassen
Passt die Breite, der markierten Zelle einer Tabelle, auf den Textinhalt an.
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 14 of 82
Suchen Panel
Suchen nach:
Hier können Sie Ihre Suchbegriffe erfassen und anschliessend auf den grünen Button klicken.
Folgende Suchmöglichkeiten bietet KnowHowDB:
l
l
l
l
mit allen Wörtern (AND Option muss gewählt werden)
mit irgendeinem der Wörter (OR Option muss gewählt werden)
mit der genauen Wortgruppe (" ")
ohne die Wörter (-)
Suchen in Kategorie:
Es wird nur in der angegebenen Kategorie und Unterkategorien nach dem Suchbegriff gesucht.
1.
2.
3.
4.
Dropdown Feld auswählen
Durchsuchen... klicken
Kategorie wählen
OK klicken
Mit dem roten X werden alle Eingaben zurückgesetzt
Nur im Titel suchen
Die Suchbegriffe werden nur im Titelfeld gesucht und das Textfeld wird für die Suche vernachlässigt.
Angehängte Links durchsuchen
Mit der Option Link Service ist es möglich angehängte Links zu durchsuchen.
Inkrementell suchen/filtern
Die "Suchresultate" Liste wird bei jeder Eingabe eines Zeichen im "Suchen nach" gefiltert.
Gefundene Wörter im Text markieren
Die gefunden Wörter werden im Textfeld markiert. Damit diese nicht verschwinden muss mit dem Scrollbalken
gearbeitet werden.
Nur nach Einträgen filtern (ohne Kategorien)
In der "Suchresultate" Liste werden die Kategorien nicht angezeigt.
Im Suchresultate Panel den Kategorienpfad anzeigen
Der Kategorienpfad wird im Panel Suchresultate angezeigt.
Eingetragen von / Geändert von / Datum geändert
Hier kann nach dem Benutzer gesucht werden, welcher einen Eintrag erstellt oder geändert hat. Ebenfalls ist es
möglich nach einem Datum zu suchen.
Page 15 of 82
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 16 of 82
Desktop Verknüpfung
ab Version 4.1
1. KnowHowDB.exe im Programmverzeichnis kopieren
2. Auf dem Desktop rechte Maustaste klicken und Verknüpfung einfügen wählen.
3. Verknüpfung umbenennen
4. Icon anwählen, rechte Maustaste klicken und Eigenschaften wählen
5. Attribut Ziel wie folgt ausfüllen:
Beispiel:
C:\Programme\KnowHowDB\KnowHowDB.exe /u"Benutzername" /p"Passwort" /e"ENVIRONMENT_ID"
l
l
l
l
/u"" = Benutzername
/p"" = Passwort
/e"" = ENVIRONMENT_ID (finden Sie entweder im EnvironmentsServer.xml oder EnvironmentsLocal.xml)
/n"" = ENVIRONMENT_NAME (finden Sie entweder im EnvironmentsServer.xml oder
EnvironmentsLocal.xml)
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 17 of 82
Outlook E-Mails in KnowHowDB ablegen
1. Gewünschtes E-Mail anwählen.
2. Per Drag and Drop in die Baumstruktur ziehen und loslassen.
3. Sicherheitsmeldung von Windows bestätigen.
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 18 of 82
Tipps und Tricks
Einträge verlinken
Ziehen Sie per Drag & Drop einen Eintrag von der Baumstruktur ins Textfeld eines anderen Eintrages. Die beiden
Einträge werden miteinander verlinkt.
Suchresultate
Suchresultate können per Drag and Drop in die Baumstruktur verschoben werden.
Bilder
Bild Dateien vom Windows Explorer können per Drag and Drop ins Textfeld gezogen werden. Sind es keine Bilder,
so werden die Dateien als Link eingefügt.
Layout
Mit dem Menü "Ansicht - Layout wiederherstellen" wird das Layout wieder auf die Werkseinstellung zurück gesetzt.
Suchen
Damit zwei Begriffe genau in dieser Wortgruppe in der Datenbank gefunden werden, muss diese Kombination in
Hochkommas gesetzt werden.
Vorlagen
Erstellen Sie einen Ordner mit all Ihren Vorlagen, damit Sie von diesen einen neuen Eintrag erfassen können.
Aktuelles Datum
Mit CTRL+. fügen Sie das aktuelle Datum ein.
Verschieben
Verschieben Sie Einträge oder Kategorien mit Drag & Drop.
Symbolleisten
Definieren Sie Ihre eigenen Symbolleisten und Tastaturkürzel.
Nur im Titel suchen
Nutzen Sie die Funktion in den Suchoptionen "Nur im Titel suchen", um die Suchtreffer zu minimieren.
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 19 of 82
Shortcuts / Tastaturkürzel
Shortcuts
Funktion
CTRL-N
Neuer Eintrag
CTRL-K
Neue Kategorie
CTRL-UMSCHALT-N
Neue Vorlage
CTRL-S
Speichern
CTRL-I
Löschen
CTRL-F4
Schliessen
CTRL-ALT-P
Seitenansicht...
CTRL-P
Drucken...
CTRL-UMSCHALT-I
Importieren...
CTRL-UMSCHALT-E
Exportieren...
CTRL-ALT-F4
Beenden
CTRL-Z
Rückgängig
CTRL-Y
Wiederholen
CTRL-X
Ausschneiden
CTRL-C
Kopieren
CTRL-V
Einfügen
CTRL-T
Einfügen als Text
CTRL-UMSCHALT-C
Format übertragen
CTRL-A
Alles markieren
CTRL-F
Suchen...
CTRL-H
Ersetzen...
CTRL-UMSCHALT-G
Berechtigungen...
F2
Normal
F3
Seitenlayout
F4
Text
CTRL-UMSCHALT-*
Formatierungszeichen
CTRL-W
Grafik...
CTRL-Q
Hyperlink...
CTRL-M
Datei...
CTRL-UMSCHALT-D
Datum...
CTRL-D
Zeichen...
CTRL-J
Styles...
CTRL-UMSCHALT-H
Absatz und Rahmen...
CTRL-UMSCHALT-A
Nummerierung und Aufzählung...
CTRL-UMSCHALT-B
Fett
CTRL-UMSCHALT-K
Kursiv
CTRL-UMSCHALT-U
Unterstrichen
CTRL-L
Linksbündig
CTRL-E
Zentriert
CTRL-R
Rechtsbündig
CTRL-B
Blocksatz
CTRL->
Vergrössern
CTRL-<
Verkleinern
CTRL-UMSCHALT-W
Benutzer-Verwalten...
CTRL-O
Optionen...
CTRL-UMSCHALT-T
Einfügen-Tabelle...
CTRL-UMSCHALT-R
Einfügen-Spalte nach rechts
CTRL-UMSCHALT-L
Einfügen-Spalte nach links
Page 20 of 82
CTRL-UMSCHALT-O
Einfügen-Zeile nach oben
CTRL-UMSCHALT-U
Einfügen-Zeile nach unten
.
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 21 of 82
Extras - Umgebung
Hier können Sie beliebig viele verschiedene Umgebungen definieren. Pro Umgebung kann jeweils eine Datenbank
hinterlegt werden. Für das Einrichten siehe Installation der Mehrplatz Version.
1. Hier werden die verschiedenen Umgebungen definiert. Pro Umgebung kann eine Datenbank definiert werden.
Dies kann bei der Enterprise Version Microsoft Access oder Microsoft SQL Server 2005 sein.
Pfad der lokalen und server Konfigurationsdateien werden ebenfalls hier einmalig definiert.
2. Im lokalen Verzeichnis werden die folgenden Dateien gespeichert:
- EnvironmentsLocal.xml
- Languages.xml; Übersetzungen der Menüs und Meldungen
- StartUpConfig.xml
3. Bei der Anmeldung können die gewünschten Umgebungen gewählt werden (lokale und server).
4. Bei der Anmeldung unter Erweitert werden dieselben Pfade der lokalen und server Konfigurationsdateien
definiert wie bei Punkt 1.
5. Im server Verzeichnis werden die folgenden Dateien gespeichert:
- EnvironmentsServer.xml
- key.krf; Lizenzschlüssel
- Languages.xml; Übersetzungen der Menüs und Meldungen
- (server).khd; KnowHowDB Datenbank File
6. - EnvironmentsServer.xml; UmgebungsID, Umgebungsname, Pfad, Konfigurationen
7. EnvironmentsLocal.xml; UmgebungsID, Umgebungsname, Pfad, Konfigurationen
8. Der lokale und server Konfigurationsdateien Pfad wird im StartUpConfig.xml gespeichert.
Page 22 of 82
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 23 of 82
Mehrplatz Installation Übersicht
KnowHowDB mit Access
Wenn KnowHowDB mit Access betrieben werden soll, so müssen die folgenden Schritte durchgeführt werden:
1. Serverumgebung einrichten
2. Clientumgebung einrichten
KnowHowDB mit SQL Server 2005 Express
Wenn KnowHowDB mit SQL Server 2005 Express betrieben werden soll, so müssen die folgenden Schritte
durchgeführt werden:
1.
2.
3.
4.
5.
6.
Installation SQL Server 2005 Express
Einstellungen SQL Server 2005 Express
Installation SQL Server Management Studio
Einstellungen SQL Server Management Studio
Serverumgebung einrichten
Clientumgebung einrichten
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 24 of 82
Installation der Mehrplatz Version
Übersicht Berechtigungen
Unter dem Menü Bearbeiten - Berechtigungen... sind die Kombinationen 1 bis 8 möglich. Die Tabelle ist
folgendermassen zu lesen. Wenn z. B. auf einen Eintrag oder Kategorie die Benutzergruppe Marketing auf
Vollzugriff (Kombination 1) berechtigt wird, hat das Marketing die Möglichkeit Neue Einträge zu erstellen, diese zu
bearbeiten, löschen, umbenennen, lesen, verschieben, exportieren, importieren und Berechtigungen zu sichten und
ändern.
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 25 of 82
Access Serverumgebung einrichten
1. Installieren Sie KnowHowDB auf einem Client, welcher mit dem Server verbunden ist.
2. Starten Sie KnowHowDB.
3. Klick auf Button Erweitert.
4. Pfad der Konfigurationsdateien auf Server wählen und mit OK bestätigen (in diesem Verzeichnis werden die
Konfigurationsdateien gespeichert.
5. Im Dropdown die Umgebung (server) wählen.
Page 26 of 82
6. Feld für Passwort leer lassen und mit OK bestätigen.
7. Umgebung einrichten:
l "Umgebungsname" frei wählbar (dieser Name wird im Anmeldefenster im Dropdown angezeigt. Jeder
Umgebung wird eine Datenbank zugewiesen.)
l Verbinden mit "Neue Datenbank" anwählen
l "Datenbank erstellen nach" wählen
l Auf Button "Testen" klicken, um die Verbindung zur Datenbank zu prüfen (Datenbank wird im
gewählten Pfad erstellt und die Verbindung geprüft).
l Button OK klicken (KnowHowDB wird mit der Server Umgebung gestartet).
8. Im Menü Extras-Benutzer-Verwalten… alle Benutzer, Benutzergruppen und Menüberechtigungen definieren.
Page 27 of 82
...zurück zur Übersicht
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 28 of 82
Access Clientumgebung einrichten
1. Installieren Sie KnowHowDB auf einem Client.
2. Starten Sie KnowHowDB.
3. Server Datenbank Pfad wählen:
l Button Erweitert anklicken.
l Pfad auf dem Server wählen.
l Mit OK bestätigen.
4. Am System anmelden.
l Mit Benutzername Hans Muster und Umgebungsname vom Server (server) anmelden.
l Mit OK bestätigen.
...zurück zur Übersicht
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 29 of 82
Installation SQL Server Express
l
l
Version 2008
Version 2005
Systemanforderungen SQL Server 2008 Express
l
l
Supported Operating Systems: Windows Server 2003 Service Pack 2; Windows Server 2008; Windows Vista;
Windows Server 2008 R2; Windows 7; Windows Vista Service Pack 1; Windows XP Service Pack 2; Windows
XP Service Pack 3;
Physical Limitations: • 32-Bit Systems: Computer with Intel or compatible 1GHz or faster processor (2 GHz or
faster is recommended. Only a single processor is supported.) • 64-Bit systems: Computer with Intel or
compatible 1.4 GHz or higher processor (2 GHz or faster is recommended. Only a single processor is
supported.) • Minimum of 512 MB of RAM (1 GB or more is recommended) • 1.9GB of free hard disk space
Installation SQL Server 2008 Express
1.
2.
3.
4.
5.
6.
7.
8.
9.
10.
Download vom SQL Server 2008 Express starten.
Installation mit der Datei SQLEXPR_x86_DEU.exe starten.
Klick links auf Installation.
Klick auf Neue eigenständige SQL Server-Installation...
Setupunterstützungsregeln mit OK bestätigen.
Bei [Product Key] Klick auf Weiter.
Bei [Lizenzbedingungen] Klick auf Ich akzeptiere... und anschliessend Klick auf Weiter.
Bei [Setup-Unterstützungsdateien] Klick auf Installieren.
Status sollte überall auf Erfolgreich stehen. Wenn ja, Klick auf Weiter.
Klick auf Alles auswählen und anschliessend auf Weiter.
11. Folgende Einstellungen vornehmen und Klick auf Weiter:
12. Bei [Erforderlicher Speicherplatz] Klick auf Weiter.
13. Bei [Serverkonfiguration] Einstellungen wie folgt vornehmen und Klick auf Weiter.
Page 30 of 82
14. Bei [Datenbankmodulkonfiguration] Einstellungen wie folgt vornehmen und Klick auf Weiter.
15. Bei [Fehler- und ...] Einstellungen wie folgt vornehmen und Klick auf Weiter.
16. Bei [Installationsregeln] Klick auf Weiter.
17. Bei [Installationsbereit] Klick auf Installieren.
18. Bei [Installationsstatus] Klick auf Weiter.
19. Bei [Abgeschlossen] Klick auf Schliessen.
Installation SQL Server 2005 Express
1. Download vom SQL Server 2005 Express starten:
http://www.incite.ch/download/treiber/sql_server_2005_express_edition_sp2.exe.
2. Installation mit der Datei sql_server_2005_express_edition_sp2.exe starten.
3. Lizenzvereinbarungen akzeptieren und Button Next klicken.
4. Button Install klicken.
5. Button Next klicken.
6. Wizard starten mit Klick auf Button Next.
7. System Check wird ausgeführt, anschliessend Klick auf Button Next.
8. Flag "Hide advanced configuration options" deaktivieren, Registrationsinformationen eingeben und Klick
auf Next.
9. Installation von allen "Client Components" aktivieren und Klick auf Button Next.
Page 31 of 82
10. "Named instance" wählen mit Bezeichung MSSQLSERVER und Klick auf Button Next.
11. Einstellungen wie folgt vornehmen und Klick auf Button Next.
12. "Mixed Mode" wählen, Passwort "sasa" eingeben und Klick auf Next.
13. Einstellungen wie folgt vornehmen und Klick auf Button Next.
Page 32 of 82
14. Enable "User Instances" aktivieren und Klick auf Button Next.
15. Beide Optionen deaktivieren und Klick auf Button Next.
16. Installation starten Klick auf Button Install.
17. Klick auf Button Next.
18. Installation abschliessen mit Klick auf Button Finish.
...zurück zur Übersicht
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 33 of 82
Einstellungen SQL Server 2005 Express
SQL Server Configuration Manager
1. Unter "Start - Programme - Microsoft SQL Server 2005 - Configuration Tools" SQL Server Configuration
Manager starten.
2. "SQL Server 2005 Network Configuration" anwählen und im Register "Protocols for MSSQLSERVER"
- "NamedPipes" auf Enabled,
- "TCP/IP" auf Enabled und
- "VIA" auf Enabled setzen.
3. "SQL Server 2005 Services" - "SQL Server (MSSQLSERVER)" wählen, rechte Maustaste drücken und
"Restart" wählen.
SQL Server Surface Area Configuration
1. Unter "Start - Programme - Microsoft SQL Server 2005 - Configuration Tools" SQL Server Configuration
Manager starten.
2. "Surface Area Configuration for Services and Connections" wählen.
Page 34 of 82
3. Folgende Einstellungen müssen vorhanden sein:
4. "Startup type" auf Automatic setzen. Anschliessend Klick auf Button Apply.
5. Klick auf Button Start.
6. Klick auf Button OK.
...zurück zur Übersicht
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 35 of 82
Installation SQL Server Management Studio
Version 2008
Wird bereits mit der Installation von SQL Server 2008 Express installiert.
Version 2005
1. Download vom SQL Server Management Studio starten:
http://www.incite.ch/download/treiber/sql_server_management_studio_express.msi
2. Installation mit der Datei sql_server_management_studio_express.msi starten.
3. Klick auf Button Next.
4. Lizenzvereinbarungen akzeptieren und Klick auf Button Next.
5. Registrierungsinformationen eingeben und Klick auf Button Next.
6. Klick auf Button Next.
7. Klick auf Button Install.
8. Klick auf Button Finish.
...zurück zur Übersicht
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 36 of 82
Einstellungen SQL Server Management Studio
1. Unter "Start - Programme - Microsoft SQL Server 2005" SQL Server Management Studio Express starten.
2. Server Name wählen und Klick auf Button Connect.
3. Rechte Maustaste auf "SQL Server…" und auf "Properties" klicken.
4. Connections wählen und sicherstellen, dass "Allow remote connections to this server" gewählt ist.
5. Klick auf Button OK.
...zurück zur Übersicht
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 37 of 82
Serverumgebung einrichten
1. Installieren Sie KnowHowDB auf einem Client, welcher mit dem Server verbunden ist.
2. Starten Sie KnowHowDB
3. Klick auf Button Erweitert anklicken.
4. Pfad der Konfigurationsdateien auf Server wählen und mit OK bestätigen (Empfohlen: gleicher Pfad wie
KnowHowDB_SQL.mdf Datenbank).
5. In diesem Verzeichnis werden die Konfigurationsdateien gespeichert.
6. Im Dropdown die Umgebung (server) wählen und Klick auf Button OK.
Page 38 of 82
7. Feld für Passwort leer lassen und mit OK bestätigen.
8. Umgebung einrichten:
l Umgebungsname erfassen. Dieser ist frei wählbar.
l Wählen Sie den Datenbank Typ Sql Datenbank.
l Server Name vom SQL Server erfassen.
l Benutzername vom SQL Server erfassen.
l Passwort vom SQL Server erfassen.
l Datenbank Name erfassen.
l Klick auf Button Datenbank erstellen und Pfad wählen (z. B. D:\Datenbanken\SQL)
l Button Testen wählen, um die Verbindung zur Datenbank zu prüfen.
l Button OK klicken.
9. Mit Benutzername SysAdmin und im Punkt 8 erfasstem Server Umgebungsname z. B. (server) anmelden. Mit
OK bestätigen.
Page 39 of 82
10. Im Menü Extras-Benutzer-Verwalten… alle Benutzer, Benutzergruppen und Menüberechtigungen
definieren.
...zurück zur Übersicht
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 40 of 82
Clientumgebung einrichten
1. Installieren Sie KnowHowDB auf einem Client.
2. Starten Sie KnowHowDB.
3. Server Datenbank Pfad wählen:
l Button Erweitert anklicken.
l Pfad auf dem Server wählen.
l Mit OK bestätigen.
4. Am System anmelden.
l Mit Benutzername Hans Muster und Umgebungsname vom Server (server) anmelden.
l Mit OK bestätigen.
...zurück zur Übersicht
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 41 of 82
Synchronisation mit SQL Server (Enterprise Edition mit Option Synchronisation)
Sollten Fehlermeldungen auftreten finden Sie hier Lösungen.
l
l
l
l
Als erstes wird der normale SQL Server eingerichtet und eine Datenbank erstellt, die KnowHowDB installiert mit
der Serverumgebung und der Clientumgebung.
Anschliessend wird auf dem Laptop ebenfalls der SQL Server installiert mit dem Unterschied, dass eine
Datenbank mit dem Datenbank Name vom Server und der Endung _Sync.mdf erstellt wird.
Jetzt wird auf dem Server die Einstellungen für die Synchronisation gemacht.
Die Datenbank kann synchronisiert werden.
Installation
1. Installation SQL Server auf dem SERVER (Siehe Kapitel Installation Mehrplatz Version - SQL Server)
1. Installation SQL Server 2005 Express
2. Einstellungen SQL Server 2005 Express
3. Installation SQL Server Mng Studio
4. Einstellungen SQL Server Mng Studio
5. SQL KnowHow Datenbank erstellen
6. Serverumgebung einrichten
7. Clientumgebung einrichten
2. Installation SQL Server LOKAL (Siehe Kapitel Installation Mehrplatz Version - SQL Server)
1. Installation SQL Server 2005 Express
2. Einstellungen SQL Server 2005 Express
3. Installation SQL Server Mng Studio
4. Einstellungen SQL Server Mng Studio
3. SQL KnowHow Datebank erstellen (Sync Datenbank)
l ACHTUNG: Beim Datenbank Name muss zwingend am Ende _Sync angeängt werden!
1. KnowHowDB LOKAL installieren.
2. Im Pfad C:\Programme\KnowHowDB\CreateSqlDatabase\Batch\ die Datei
CreateDatabase_Deutsch.bat starten
3. Benutzername vom SQL Server eingeben (z. B. sa) und mit ENTER bestätigen.
4. Passwort vom SQL Server eingeben (z. B. sasa) und mit ENTER bestätigen.
5. Server Name vom SQL Server eingeben (z. B. WINXP\EXPRESS) und mit ENTER bestätigen.
6. Beliebiger KnowHowDB Datenbank Name eingeben (z. B. KnowHowDB_SQL_Sync) und mit
ENTER bestätigen.
7. Beliebiger KnowHowDB Datenbank Pfad eingeben (unbedingt Backslash \ am Ende des Pfades)
und mit ENTER bestätigen.
8. Die SQL Datenbank wird erstellt (mit der Meldung Installation finished! ist dieser Prozess beendet).
l
ACHTUNG: die Passwörter der beiden SQL Server SERVER und LOKAL müssen gleich sein!
Page 42 of 82
4. KnowHowDB starten.
5. Klick auf Button Erweitert anklicken.
6. Pfad der Konfigurationsdateien auf Server wählen und mit OK bestätigen (Empfohlen: gleicher Pfad wie
KnowHowDB_SQL.mdf Datenbank).
7. Anmelden an der Serverumgebung (server) mit Benutzer SysAdmin.
8. Extras - Optionen - Synchronisation aktiv auf True setzen.
9. Extras - Optionen - Datenbanktyp für Synchronisation wählen (SQL Server).
10. Applikation schliessen.
11. Anmelden mit einem beliebigen Benutzer am Server.
12. Beim Start dieses Fenster mit Ja bestätigen.
Page 43 of 82
13. Falls diese Meldung erscheint SQL Server Lokal wählen und mit Klick auf OK bestätigen.
14. Synchronisation wird mit dem Protokoll abgeschlossen.
15. Klick auf Schliessen.
16. Applikation schliessen.
17. Die Applikation kann jetzt mit einem Benutzer Lokal gestartet werden, da die Datenbank in das lokale
Verzeichnis synchronisiert wurde. Der Serverumgebung (server) wird jetzt noch ein _Sync angehängt.
Page 44 of 82
Copyright © 2009 Incite GmbH. Alle Rechte vorbehalten. 31.08.2009.
Page 45 of 82
Synchronisation mit Access (Enterprise Edition mit Option Synchronisation)
1. Installation Mehrplatz Version durchführen (Access)
2. Anmelden an der Serverumgebung mit Benutzer SysAdmin
3. Extras - Optionen - Synchronisation aktiv auf True setzen
4. Extras - Optionen - Datenbanktyp für Synchronisation wählen (Access oder SQL)
5. Applikation schliessen
6. Anmelden mit einem beliebigen Benutzer am Server
7. Beim Start dieses Fenster mit Ja bestätigen
8. Synchronisation wird mit dem Protokoll abgeschlossen
Page 46 of 82
9. Klick auf Schliessen
10. Applikation schliessen
11. Die Applikation kann jetzt mit einem Benutzer Lokal gestartet werden, da die gesamte Datenbank auf das
lokale Verzeichnis kopiert wurde. Der Name wird von der Server Datenbank übernommen und ein _Sync
angehängt
Copyright © 2009 Incite GmbH. Alle Rechte vorbehalten. 31.08.2009.
Page 47 of 82
Tips und Spezifikationen Synchronisation
Tips
Folgend noch einige wichtige Tips:
l
l
Synchronisation kann auch über das Menü Extras - Datenbank - Datenbank synchronisieren... gestartet
werden.
Jeder Benutzer kann in den Extras - Optionen - Synchronisieren beim Programmstart wählen, ob das Fenster
beim Starten erscheint.
Spezifikationen
Page 48 of 82
1.
2.
3.
4.
5.
6.
7.
8.
9.
10.
l
Alle Änderungen an bestehenden Einträgen auf der Server DB werden auf Lokal DB geschrieben.
Alle Änderungen an bestehenden Einträgen auf Lokal DB werden von der Server DB überschrieben.
Alle neuen Einträge auf der Server DB werden inkl. Links und Bilder auf Lokal DB kopiert.
Alle neuen Einträge auf der Lokal DB werden inkl. Links und Bilder auf Server DB kopiert.
Wird ein Eintrag auf Server DB gelöscht, so wird dieser auf Lokal DB ebenfalls gelöscht.
Wird ein Eintrag auf Lokal DB gelöscht, so wird dieser auf Server DB nicht gelöscht.
Wird ein Eintrag auf Server DB verschoben, so wird dieser auf Lokal DB ebenfalls verschoben.
Wird ein Eintrag auf Lokal DB verschoben, so wird dieser auf Server DB nicht verschoben.
Wird ein Eintrag auf Server DB umbenannt, so wird dieser auf Lokal DB umbenannt.
Wird ein Eintrag auf Lokal DB umbenannt, so wird dieser auf Server DB nicht umbenannt.
Berechtigungen werden von der Server DB auf die Lokale DB kopiert, d. H. dass gesperrte Einträge auch auf der
Lokalen DB gesperrt bleiben.
Copyright © 2009 Incite GmbH. Alle Rechte vorbehalten. 31.08.2009.
Page 49 of 82
Fehlerbehebung
Inhaltsverzeichnis
l
Login failed for user 'sa'
l
Synchronisation
Login failed for user 'sa'
Diese Fehlermeldung erscheint, wenn die Server und Lokal SQL Server unterschiedliche Passwörter haben.
1. KnowHowDB starten mit SysAdmin und lokaler Synchronisationsumgebung (server)_Sync.
2. Fehlermeldung mit OK bestätigen.
Page 50 of 82
3. Passwort vomSQL Server SERVER (nicht lokaler SQL Server) eingeben und mit OK bestätigen.
4. Passwort kann jetzt geändert werden auf das des lokalen SQL Servers. Mit OK bestätigen.
5. KnowHowDB kann wieder gestartet werden.
Page 51 of 82
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 52 of 82
Installation Link Service
1. Installation von der kostenlosen Software iFilter von der Firma Adobe.
2. KnowHowDB auf dem Server Installieren.
3. Pfad der Datenbank-Dateien wählen.
4. KnowHowDB mit der Key.krf Datei freischalten.
5. KnowHowDB starten.
6. Link Service unter "Extras - Link Service..." starten.
7. Pfad für Konfigurationsdatei muss gewählt werden. Es wird empfohlen dasselbe Datenbank-Dateien Verzeichnis
wie bei der KnowHowDB zu wählen.
Page 53 of 82
8. Register "Umgebungen" wählen.
9. Button Neu klicken und im Register "KnowHowDB" eine bestehende KnowHowDB Datenbank-Datei .khd
wählen .
10. Im gleichen Fenster im Register "IndexDB" eine Index Datenbank wählen, in welcher der indexierte Text
abgelegt werden soll.
11. Auf Button "Datenbank prüfen" klicken -> Meldung Verbindung erfolgreich muss angezeigt werden.
12. Die Oberfläche sollte in etwa so aussehen:
13. In der KnowHowDB Extras-Optionen... wählen.
14. Datenbanktyp, Datenherkunft (IndexDB) und wenn nötig ein Passwort bestimmen (beim SQL Server wird noch
der Datenbankname, Sql-Server Benutzername und Passwort benötigt)
15. Fenster Link Service öffnen und mit dem Button "Start Service" den Service starten.
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 54 of 82
Anleitung Link Service
Der Link Service wird von der KnowHowDB benötigt, damit bei einer Suche der Suchbegriff nicht nur in einem
Eintrag, sondern auch in den angehängten Links gefunden werden kann. Alle erkennbaren Dateiendungen werden
vom Link Service indexiert und als Text in einer Index-Datenbank gespeichert. Windows erkennt standardmässig
bereits einige Endungen. Damit z. B. PDF durchsucht werden können, wird ein sogenannter iFilter benötigt, welcher
dem Link Service das indexieren von PDF ermöglicht. Weitere iFilter können nach belieben installiert werden.
Der Link Service sollte bei der Mehrplatz Version auf einem Server und bei der Einzelplatz Version auf dem Client
installiert werden.
Folgende Dateien werden indexiert:
.pdf
Adobe PDF
.doc
Microsoft Word
.html
Webseite
.xls
Microsoft Excel
.ppt
Microsoft PowerPoint
.txt
Windows Text Files
.log
Log Files
.xml
Extensible Markup Language
Register Informationen
Hier werden verschiedene Informationen der Indexierung angezeigt. Die folgenden Zeilen wiederholen sich bei jedem
Indexierungs-Intervall.
1. Beim Starten vom Link Service wird auf der 1. Zeile "Indexierung gestartet" angezeigt.
2. Wenn die Indexierung beendet ist, wird das Logfile geschrieben und auf der 2. Zeile angezeigt.
3. Am Schluss wird auf der 3. Zeile "Indexierung fertig" angezeigt
Tipp: Doppelklick auf diese Zeile öffnet das Logfile.
Register Umgebungen
Hier können beliebig viele Umgebungen, welche indexiert werden sollen, definiert werden. Einerseits muss der Link
Service die Datenbank (KnowHowDB.khd) kennen, aus welcher er die Links indexieren und andererseits in welche
Page 55 of 82
Datenbank (IndexDB.khi) er die indexierten Text schreiben soll.
Neu
Mit dem Button "Neu" wird eine neue Umgebung definiert.
Bearbeiten
Mit dem Button "Bearbeiten" wird eine bestehende Umgebung geändert.
Löschen
In der 1. Spalte "Indexieren" besteht die Möglichkeit eine Umgebung von der Indexierung auszuschliessen.
Register Allgemeines
Hier können diverse Einstellungen vorgenommen werden.
Page 56 of 82
Planen
Einstellung wann die Indexierung erfolgen soll. Entweder täglich um eine bestimmte Zeit oder jede x-te Stunde,
Minute oder Sekunde.
Log
Wird eine der beiden Einstellungen aktiviert, so wird ein Log File erstellt.
Programmsprache
Sprache der Oberfläche kann gewählt werden.
Dateiendungen
Hier können zusätzliche Endungen angegeben werden. Der Linkservice versucht die Datei als Text File einzulesen.
Konfigurationspfad
Hier werden die Einstellungen vom Link Service in Form einer XML Datei abgelegt.
Registration
Die Registrationsdatei Key.krf wird automatisch von der KnowHowDB übernommen, falls der Konfigurationspfad der
KnowHowDB und vom Link Service übereinstimmen.
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 57 of 82
Bedienung Link Service
Wenn z. B. nach dem Begriff Indexierung gesucht wird, so wird dieser Begriff im Titel, im Eintrag selber und in den
Inhalten der Links gefunden und entsprechend markiert. In diesem Fall wird der Begriff Indexierung auch im PDF
Dokument Indexierung.pdf und im HTML Dokument Indexierung.html gefunden.
In der Liste wird der Eintrag aufgeführt, da der Begriff Indexierung sich im Titel und Eintrag befindet und 2 Mal als
Link, da er sich auch in diesen befindet.
Tipp: Soll der Suchbegriff nur im Eintrag und nicht in den Links gesucht werden, so deaktivieren Sie
folgende Option:
Page 58 of 82
Tipp: Mit der rechten Maustaste auf den Link in der Liste klicken, so wird der entsprechende Link im
dazugehörigen Programm geöffnet.
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 59 of 82
Aufgabenplanung (Task Scheduler)
Der Link Service kann in der Aufgabenplanung automatisch gestartet werden, indem nach dem
Programmverzeichnis und dem linkservice.exe ein /a1 mitgegeben wird.
Das /a1 steht für Service starten.
c:\programme\knowhowdb\linkservice.exe /a1
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 60 of 82
Metadaten
Einleitung
Mit den Metadaten besteht die Möglichkeit Daten strukturiert ausserhalb vom Textfeld zu verwalten. Es können
beliebig viele Attribute der KnowHowDB hinzugefügt werden. Bei den Attributen lassen sich Typen wie Textfelder,
nummerische Felder, Datum, Auswahl (Dropdown), Schalter (Checkbox), Option und Gruppe wählen.
Diese Metadaten lassen sich mit Vorlagen gruppieren, indem man eine Metadaten-Vorlage eröffnet und beliebige
Attribute zuweist.
Die Metadaten-Vorlage kann einer Kategorie mit seinen Unterkategorien und einem Benutzer oder Gruppe
zugewiesen werden.
Erstellt jetzt der Benutzer xy in einer Kategorie z. B. Support einen neuen Eintrag, so werden in einem Panel alle
entsprechenden Attribute wie Problemstellung, Lösung, Kunde, ... angezeigt und können editiert werden.
Zudem können einzelne Metadaten Attribute gesucht werden und in der Suchresultate-Liste eingeblendet werden.
Alle Metadaten Attribute können im Textfeld angezeigt und somit gedruckt werden.
Page 61 of 82
Vorgehen
1.
2.
3.
4.
5.
Attribute definieren
Metadaten Vorlage erstellen, Attribute zuweisen und Reihenfolge bestimmen
Vorlage für Eintrag erstellen
Metadaten Vorlage und Eintrag Vorlage einer Kategorie und Benutzer/Gruppe zuweisen
Neuer Eintrag mit Metadaten erstellen
Schritt 1
Schritt 2
Schritt 3
Schritt 4
Schritt 5
Attribute definieren
Vorlage Metadaten
Vorlage Eintrag
Zuw eisung
Neuer Eintrag
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 62 of 82
Schritt 1 - Attribute definieren
Schritt 1
Schritt 2
Schritt 3
Schritt 4
Schritt 5
Attribute definieren
Vorlage Metadaten
Vorlage Eintrag
Zuw eisung
Neuer Eintrag
1. Menü Extras - Metadaten - Metadaten bearbeiten klicken
2. Klick auf Neu
3. Attribut definieren
Page 63 of 82
Beschreibung der einzelnen Formular Eingenschaften:
Name
Name des Attributes
Typ
Es kann zwischen verschiedenen Typen gewählt werden.
Breite
Automatisch: das Attribut wird automatisch an die Breite
vom Panel angepasst.
Wert: exakte Breite in Pixel
Spaltenbreite in
Suchresultate-Liste
Exakte Breite in Pixel in der Suchresultate-Liste.
Mehrzeilig
Ein Text-Attribute kann mehrzeilig angezeigt werden.
Durchsuchbar
Nach diesem Attribut kann gesucht werden. Es wird im
Dropdown Menü angezeigt.
Vorhandene Daten für
die Suche abfüllen
Ist diese Option gewählt, so wird das Such Dropdown Feld
automatisch mit den bestehenden Daten abgefüllt. Sodass
eine Auswahl bestehender Daten möglich ist.
Standartwert
Dieser Wert wird automatisch bei einem neuen Eintrag
abgefüllt.
Dezimalstellen
Bei einer Zahl kann die Anzahl Kommastellen gewählt
werden.
Minimaler Wert
Minimaler Wert eines Zahlen Attribut.
Maximaler Wert
Maximaler Wert eines Zahlen Attribut.
Eintrags-ID (Auto-ID)
Fortlaufender automatischer eindeutiger Wert.
Auswahlliste
Hier werden die Daten definiert, welche in einem Auswahl
Attribut angezeigt werden sollen.
Attribut Typen
1.
2.
3.
4.
5.
6.
7.
8.
Zahl: definiert als Eintrags-ID (Auto-ID), fortlaufende Nummerierung
Text: normale Textbox
Text: Textbox definiert als Mehrzeilig
Auswahl: Dropdown Menü mit beliebig vielen Einträgen, mit Option "nur Listeneinträge erlauben"
Schalter: Checkbox zum anwählen für Ja / Nein Werte
Gruppe: bestehend aus 2 Text-Attribute und einem Datums-Attribut
Datum: es kann nur ein Datum erfasst werden
Option: Gruppe mit 3 Options-Attribute
Page 64 of 82
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 65 of 82
Schritt 2 - Metadaten Vorlage erstellen, Attribute zuweisen und Reihenfolge bestimmen
Schritt 1
Schritt 2
Schritt 3
Schritt 4
Schritt 5
Attribute definieren
Vorlage Metadaten
Vorlage Eintrag
Zuw eisung
Neuer Eintrag
1.
2.
3.
4.
5.
Menü Extras - Metadaten - Metadaten Vorlage bearbeiten klicken
Vorlage erstellen mit Klick auf Neu
Vorlage markieren und gewünschte Attribute mit Pfeilen rechts und links verschieben
Reihenfolge mit Pfeilen hoch und runter bestimmen
Beliebige Attribute können per Drag & Drop in eine Gruppe gezogen werden
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 66 of 82
Schritt 3 - Vorlage für Eintrag erstellen / Metadaten Attribut einfügen
Schritt 1
Schritt 2
Schritt 3
Schritt 4
Schritt 5
Attribute definieren
Vorlage Metadaten
Vorlage Eintrag
Zuw eisung
Neuer Eintrag
1.
2.
3.
4.
Menü Eintrag - Neue Vorlage klicken
Vorlage bezeichnen
Layout wie gewünscht gestalten mit Text, Tabellen und Logo
Metadaten Attribute mit dem Menü "Einfügen - Metadaten-Attribut einfügen..." einfügen. Die Attribute werden in
Klammern <<Attribut>> angezeigt
5. Speichern und schliessen
Page 67 of 82
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 68 of 82
Schritt 4 - Metadaten Vorlage zuweisen
1.
2.
3.
4.
5.
6.
7.
Schritt 1
Schritt 2
Schritt 3
Schritt 4
Schritt 5
Attribute definieren
Vorlage Metadaten
Vorlage Eintrag
Zuw eisung
Neuer Eintrag
In der Baumstruktur Kategorie auswählen
Rechte Maustaste klicken und "Vorlage zuweisen" klicken
Gruppe oder Benutzer von "vorhandene Benutzer/Gruppen" in "Benutzer oder Gruppe" ziehen
Verschobener Benutzer oder Gruppe markieren
Metadaten-Vorlage auswählen
Eintrag-Vorlage auswählen
"OK" klicken
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 69 of 82
Schritt 5 - Neuer Eintrag erstellen
1.
2.
3.
4.
Schritt 1
Schritt 2
Schritt 3
Schritt 4
Schritt 5
Attribute definieren
Vorlage Metadaten
Vorlage Eintrag
Zuw eisung
Neuer Eintrag
In der Baumstruktur Kategorie auswählen.
Rechte Maustaste klicken und "Neuer Eintrag" wählen.
Metadaten können jetzt im Panel Metadaten ausgefüllt werden.
Beim Speichern werden die Metadaten im Textfeld aktualisiert.
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 70 of 82
Suchen von Metadaten
1.
2.
3.
4.
5.
Suchbegriffe eingegeben, welche in der ganzen Datenbank gefunden werden.
Wird diese Checkbox aktiviert, so werden auch Metadaten mit der Suche von Punkt 1 gefunden.
Spezifisch nur nach dem Metadaten Attribut "Problemstellung" suchen.
Suchbegriffe der Metadaten eingegeben.
Wird diese Checkbox aktiviert, so wird dieses Metadaten Attribut in der Suchresultate-Liste eingeblendet, siehe
Punkt 7.
6. Weitere Metadaten Attribute können für die Suche aktiviert werden.
7. Die Attribute von Punkt 5 werden angezeigt.
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 71 of 82
Export von Metadaten
1. Gewünschte Einträge suchen
2. Menü "Eintrag - Exportieren..." wählen
3. Option wählen z. B. "Alle Suchresultate"
4. Format, Metadaten-Liste generieren und Zielpfad wählen
5. Die Einträge werden als PDF exportiert und die Metadaten als CSV. Die CSV Datei kann im Excel geöffnet
werden.
Copyright
2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 72 of 82
Berechtigung von Metadaten
Wenn in den Berechtigungen einem Benutzer z. B. Peter Urech die Berechtigung "Vorlagen und Metadaten" zu
bearbeiten weg genommen wird, so kann er den Kategorien keine Metadaten- oder Eintrag-Vorlagen zuweisen.
Page 73 of 82
Zudem kann dieser Benutzer die Metadaten-Attribute nicht entsperren im Eintrag und somit auch nicht bearbeiten
oder löschen.
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 74 of 82
Beispiele Vorlagen
Beispiel Bericht
Beispiel Brief
Beispiel Protokoll
Page 75 of 82
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 76 of 82
Exportieren...
KnowHowDB bietet die folgenden Exportmöglichkeiten:
l
l
l
l
l
l
KnowHowDB .xml
Adobe PDF .pdf
MIcrosoft Word .doc
Webseite .html
Rich Text .rtf
Text .txt
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 77 of 82
Importieren...
KnowHowDB bietet die folgenden Importmöglichkeiten:
l
l
l
Datenimport von älteren KnowHowDB Versionen
Datenimport von XML Dateien (Exportiert von KnowHowDB oder einer anderen Applikation, wobei das Format der
Konvention von KnowHowDB entsprechen muss.)
Datenimport von folgenden Dateien:
l Word Dokumente .doc
l Richtext .rtf
l Textdateien .txt.
l Webseiten .html
Import ab Version 2.42
Es besteht die Möglichkeit alle Einträge mit Text, Kategorien, Bilder und Links einer Datenbank von einer älteren
Version ab 2.42 in 2 Schritten zu Importieren.
1. Menü Eintrag-Importieren... wählen
2. Klick auf KnowHowDB (*.khd)
3. Pfad einer alten KnowHowDB Version wählen
4. Weiter klicken
5. Einzelne oder alle Einträge markieren
Page 78 of 82
6. Wählen Sie eine der folgenden Optionen:
l Ordner Struktur übernehmen; die Einträge werden entweder mit oder ohne Kategorien importiert.
l Unter Arbeitsplatz einfügen; die Einträge werden unter dem Arbeitsplatz eingefügt.
l In die aktuelle Kategorie einfügen; die Einträge werden in der zuletzt markierten Kategorie
eingefügt.
7. Klick auf Importieren
8. Klick auf Schliessen
Datenaustausch mit anderen Applikationen
Mit dem Format .XML ist es einerseits möglich einen Datenaustausch innerhalb verschiedener KnowHowDB
Datenbanken und andererseits zu anderen Applikationen zu machen. Dabei werden Text, Bilder, Kategorien und
Links berücksichtigt. 1. Menü Eintrag-Importieren... wählen
2. Klick auf KnowHowDB (*.xml)
3. Pfad einer XML Datei wählen
4. Klick auf Schliessen
Dateien und Ordner
Mit dieser Variante können beliebig viele Daten per Knopfdruck aus dem Windows Explorer importiert werden. Sind
es bekannte Formate wie .DOC, .RTF, oder .TXT, so werden die Texte und Bilder dieser Dateien in KnowHowDB
Einträge importiert. Der Titel wird vom File übernommen. Werden Formate nicht erkannt, so werden diese in der
Linkliste verlinkt.
1. Menü Eintrag-Importieren... wählen
2. Klick auf Dateien und Ordner
Page 79 of 82
3. Ordner und Dateien wählen
4. Wählen Sie eine der folgenden Optionen:
l Nur bekannte Formate importieren; es werden nur Dateien des Typs .doc, .rtf, .txt eingelesen. Sie
werden komplett eingelesen und die spätere Suche nach Stichworten ist möglich.
l Bekannte Formate importieren, unbekannte Formate nur als Link importieren; es werden
Dateien des Typs .doc, .rtf, .txt eingelesen und die restlichen in der Linkliste verlinkt.
l Alle nur als Link importieren; alle Dateien werden in der Linkliste verlinkt.
l Unter Arbeitsplatz einfügen; die Einträge werden unter dem Arbeitsplatz eingefügt.
l In die aktuelle Kategorie einfügen; die Einträge werden in der zuletzt markierten Kategorie
eingefügt.
5. Klick auf Importieren
6. Klick auf Schliessen
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 80 of 82
Benutzer-Verwalten...
Neuer Benutzer
1.
2.
3.
4.
5.
Klicken Sie auf das Menü Benutzer-Verwalten...
Klicken Sie auf das Register Benutzer.
Klicken Sie auf Neu.
Geben Sie den Benutzernamen ein und wählen die Sprache. Passwort und Bemerkungen sind optional.
Klicken Sie auf OK.
Neue Benutzergruppe
1.
2.
3.
4.
5.
Klicken Sie auf das Menü Benutzer-Verwalten...
Klicken Sie auf das Register Benutzergruppen.
Klicken Sie auf Neu.
Geben Sie die Benutzergruppe ein. Bemerkungen ist optional.
Klicken Sie auf OK.
Benutzer einer Benutzergruppe zuweisen
1. Klicken Sie auf das Register Benutzer.
2. Wählen Sie in der oberen Liste den gewünschten Benutzer aus.
3. Doppelklicken Sie in der unteren rechten Liste eine gewünschte Benutzergruppe. Die Benutzergruppe wird in die
untere linke Liste übernommen.
Bemerkungen
Der Vorteil liegt darin, dass beliebig viele Mitarbeiter (Benutzer) einer Abteilung (Benutzergruppe) zugewiesen
werden können und bei der Berechtigung eines Eintrages und/oder Kategorie, muss nur die Benutzergruppe
berechtigt werden. Alle Mitarbeiter in dieser Abteilung haben nun die gleichen Rechte.
Menüberechtigungen
1.
2.
3.
4.
Klicken Sie auf das Register Menüberechtigungen.
Doppelklicken Sie auf der oberen rechten Liste auf einen beliebi-gen Benutzer oder Benutzergruppe.
Wählen Sie nun diesen auf der oberen rechten Liste an.
Berechtigen Sie nun unten die gewünschten Menüs.
Bemerkungen
Mit dieser Funktion lassen sich alle Menüs pro Benutzer oder Benutzergruppe ein- und ausblenden. Dies hat den
Vorteil, dass z. B. das Menü Extras-Benutzer-Verwalten... für alle Benutzer deaktiviert werden kann. Somit kann
nur der Systemadministrator die Benutzer, Benutzergruppen und Menüberechtigungen definieren. Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 81 of 82
Optionen...
Es stehen einige Optionen zur Verfügung, welche individuell angepasst werden können.
Sprache
Hier können Sie die Sprache der Programmoberfläche wählen
Links markieren
Bei True werden die Links in der Linksliste, welche nicht mehr gefunden werden können, markiert.
Ansicht
Hier stehen Ihnen verschiedene Designs der Programmoberfläche zur Verfügung.
Eintrag anzeigen
Bei True wird beim durchblättern von Einträgen in der Suchliste oder in der Baumstruktur der Eintrag erst angezeigt,
wenn die ENTER Taste gedrückt wird.
Datenbank Name
Dieser Name wird in der Programmoberfläche im Register Tab angezeigt.
Datenbankversion
Zeigt die aktuelle Version der Datenbankstruktur an.
Historie aktiv
Hier wird bestimmt, ob die Historie aktiv ist und bei jedem Speichern ein Historie Eintrag gemacht wird. So lassen
sich beliebige Versionen von einem Eintrag wieder herstellen.
Standardpfad für Bilder
Standardpfad für referenzierte Bilder im Textfeld. Die Struktur wird automatisch von KnowHowDB organisiert.
Standardpfad für Links
Relativ hinzugefügte Links werden zu diesem Pfad verlinkt.
Verlinkte Dateien löschen
Steht diese Einstellung auf True, dann werden Links von gelöschten Einträgen ebenfalls gelöscht.
Vorlage für neuer Eintrag
Sie können den aktuell geöffneten Eintrag als Standardvorlage für einen neuen Eintrag definieren. Klicken Sie rechts
von dieser Zeile auf den Knopf "..." wenn Sie den aktuell geöffneten Eintrag übernehmen möchten.
Copyright © 2010 Incite GmbH. Alle Rechte vorbehalten. 06.01.2010.
Page 82 of 82
Document
Kategorie
Internet
Seitenansichten
22
Dateigröße
7 091 KB
Tags
1/--Seiten
melden